Wireless Connection problem - constant drop outs (Intel Pro 3945ABG wireless NIC)

Discussion in 'Networking & Internet' started by huey85, Feb 13, 2007.

  1. huey85

    DamnFool

    Joined:
    Feb 1, 2008
    Messages:
    3
    Likes Received:
    0
    Yes. Current setting is:



    TCP Global Parameters

    ----------------------------------------------

    Receive-Side Scaling State : disabled

    Chimney Offload State : enabled

    Receive Window Auto-Tuning Level : disabled

    Add-On Congestion Control Provider : none

    ECN Capability : disabled

    RFC 1323 Timestamps : disabled
     
    DamnFool, Feb 7, 2008
    1. Advertisements

  2. huey85

    netgearman

    Joined:
    Jan 30, 2008
    Messages:
    3
    Likes Received:
    0
    run the most up to date windows updates and everytime it happens and it gives u the opt to send a report send a report to microsoft seems like the issue is fixed or at least not as bad as i haven't had a drop in a few days so i'm not sure what changed but so far so good
     
    netgearman, Feb 17, 2008
    1. Advertisements

  3. huey85

    jonico

    Joined:
    Apr 13, 2008
    Messages:
    1
    Likes Received:
    0
    Wow. I've read all 102 posts, and fiddled with my HP new Presario desktop as far as I can go. Still get consistent and constant drop from my wireless router-adsl internet connection. It connects to the net for a few seconds, sometimes enough to load a page in IE (usually not, tho). It doesn't stay connected long enough to get any of the vista patches & updates downloaded, so that's out of the question.

    Google shows lots of forums where we're all complaining about the same issue. It's clearly Vista, because I've brought over a friend's clunky Toshiba laptop running XP, and it works fine and the router's happy and the network is happy.

    Has anyone seen reference to Microsoft actually acknowleding this connectivity problem, and what they're thinking of doing? Some of you great folks here have been doing some pretty heavy duty troubleshooting work, and I really appreciate it. I'd really really like to be able to appreciate MS's not requiring us to go through this hell, tho.

    So none of this stuff has worked. Any suggestions?
     
    jonico, Apr 13, 2008
  4. huey85

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA


    Not to defend MS, but what folks are missing here is that this is an INTEL chipset, not MS, and Intel ALWAYS writes their own drivers. I have the infamous 915GM INTEL chipset on a laptop, and it does NOT support Aero. Why? Because INTEL decided to NOT write drivers for their own chipset to support Aero.



    So, if you want to complain, then complain to the right company -- Intel.
     
    WAW8, Apr 13, 2008
  5. huey85

    twhansen

    Joined:
    May 3, 2008
    Messages:
    1
    Likes Received:
    0
    Hi guys.



    It seems that quite a few people are experiencing this problem. Has anyone managed to solve it? I am using a Netgear WGR614 wireless router and an Intel 4965AGN wireless adapter on a Windows Vista Ultimate based laptop. My internet connection drops out constantly. I don't know if it is just me getting more and more frustrated, but it seems that the drop-out frequency is increasing. After reading almost all posts on this board, I have tried:



    1) disable IPv6

    2) disable Teredo tunneling pseudo interface

    3) disable auto tuning



    Unfortunately none of it has remedied the situation. For the time being my Vista installation seems perfectly useless for internet use. Fortunately I have a dual boot installation with XP and here things work perfectly.



    Has anybody come up with a solution?
     
    twhansen, May 3, 2008
  6. huey85

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Please don't tag an off-topic post onto a specific thread. This post is about problems with a specific Intel wireless chipset, not about generic wireless problems.



    If you're having problems with other chipsets, read through the pinned posts we have. Wireless seems to be an ongoing problem with Vista.
     
    WAW8, May 3, 2008
  7. huey85

    tanmilk

    Joined:
    May 10, 2008
    Messages:
    1
    Likes Received:
    0
    Hi,



    Have just tried to update the driver to the XP version, however every time I uninstall the wireless card Vista automatically installs the same driver again. I have gone into advanced system settings>hardware>windows update driver settings, have changed the settings from automatic but it still installs the same driver.



    Having to sit by my wireless router with a wireless laptop is getting a little annoying!!



    thanks in advance
     
    tanmilk, May 10, 2008
  8. huey85

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Since you're clearly having a "drivers" problem, you should be reading the pinned posts in our Drivers forum. We have a couple there that provide instructions for removing drivers from the driverstore -- so Vista can NOT automatically reinstall them again.
     
    WAW8, May 10, 2008
  9. huey85

    zirconia

    Joined:
    Jun 10, 2008
    Messages:
    1
    Likes Received:
    0
    So my girlfriends laptop has been having this same issue and to no avail could I find any information about it. I decided to go into the device manager and look at the device properties. I went through all the tabs and didn't see anything too alarming then I found what I suspect had been causing the random drop outs. I clicked the power management tab and what do i see checked? Allow the computer to turn the device on and off to save power. I unchecked that and haven't had any drop out issues since. Hope that helps some of you!
     
    zirconia, Jun 10, 2008
  10. huey85

    dfamqwrkrten

    Joined:
    Aug 24, 2008
    Messages:
    1
    Likes Received:
    0
    I'm posting this because I suffered through an increasingly bad wireless connection for months, even though an XP machine in my house had zero problems connecting. It would drop the connection to the Internet, then drop the connection to my Network/Router, then connect again after a few minutes but go agonizingly slow. Finally last weekend,ithardly connected at all despite repeated attempts to Repair Connection, Reset Adapter, get new IP Settings, etc.

    Now that I've got it fixed, I wanted to put all the things I did into one post in case it helps someone else.

    I sifted through at least a dozen websitesand ultimately I tried 11 tweaks. It's now been 8 days without a single dropout, AND my connection speed is much faster. Here are the 11 things I gleaned from across many sites (including this one), in the hope that these help you. I won't describe exactly how to do each of these or why it *might* be important, because it's covered in lots of other posts here.

    1) Change the channel on your router from 6 to 12. Ultimately, I think this was the most importantthing for my situation.

    2) In your Wireless Connection Network Properties, "Networking" tab, disable QoS Packet Scheduler. Don't need it.

    3) In your Wireless Connection Network Properties,"Networking" tab, disable Internet Protocol Version 6 (IPv6). You <U>must</U> leave IPv4 enabled, you need this.

    4) In your Wireless Connection Network Properties, "Networking" tab, disable both of the LinkLayer Topolgies. Don't need it.

    5) Switch the power setting on your Wireless Adapter to "Max" or "Always On". Powering it up and down to save energy *might* cause connection problems.

    6) Disable UPnP (Universal Plug and Play) on your router. This feature can be handy in some cases, but *might* cause connection problems.

    7) Get the latest firmwarefrom your router manufacturer's website, and install it. Some router manufacturers have updated their router firmware for Vista.

    8) Enable "Broadcastmy SSID" on your router. Some people think that unbroadcasted SSIDs don't connect properly in Vista. A diagnostic test on my machine flagged this too. It *might* cause connection problems.

    9) Disable Wireless Security on your router. I've since turned this back on (WPA-TKIP) with no connection problems, and <U>it's critical to turn this back on if you broadcast your SSID</U>.

    10) Turn off Windows Firewall. Some folks think the handling of packets by Windows Firewall (and other firewalls) *might* cause connection problems. I've since turned this back on just to be safe, even though I'm behind a router.

    11) Turn your Wireless Adapter's romaing tendency to "conservative" or "minimum". Don't let it roam in "aggressive" or "maximum" or "seek best connection" mode.

    I hope this post helps you, since it took me the better part of a day to sift many, many forum posts across multiple web sites to find all these possible fixes.

    In case any MS staffers see this post and want to know my equipment: Dell Inspiron 530, Vista Home Premium, Core2Quad, 4GB RAM, with Broadcom 802.11g Network Adapter.

    BTW, it's obvious after going through so many posts (including some posts where MS staffers were asking questions) that Microsoft knows this is widespread and doesn't know how to fix it yet. It's increasingly hard to believe they didn't see this problem before they released Vista.

    Good luck!!!

    Keywords to help others find this information when they search like I did:

    Windows Vista Dropped Wireless Connection Network Won't Connect Slow Drop Internet Connectedness
     
    dfamqwrkrten, Aug 24, 2008
  11. huey85

    insats

    Joined:
    Aug 27, 2008
    Messages:
    7
    Likes Received:
    0
    I've read through the whole thread now but none of the solutions seem to work. I have the exakt same problems as the first (and some of the other) posters.

    I can easily force it to occur by going to www.diablo3.com and playing the two trailers over and over again (empty cache in between). This always make the problem occur.



    I've googled my *** off about this, and this thread has so far been the one with the most users experiencing the same thing



    So far I've tried:



    (using Zepto Znote 6214W laptop with Intel Pro/Wireless 3945 running vista x64 SP1)



    -Tried several different router firmware (including dd-wrt)



    -Turned off UPnP on the router (have heard it helps)



    -Tried a registry tweak adding "DhcpConnDisableBcastFlagToggle" with value "1" to the NIC registry. (supposed to help, but didn't)



    -Turned off all energy saving options for the NIC (network interface controller)



    -Tried several different drivers for the NIC (currently using the latest)



    -Tried several different options in the configuration for the NIC



    -Ran the command: netsh int tcp set global autotuninglevel=disable (supposed to help, but didn't)



    -Unchecked IPv6



    -Unchecked QoS and the two layer stuff things.



    Please HELP!



    I've tried everything, but haven't found a solution yet and this is getting very frustrating!
     
    insats, Aug 27, 2008
  12. huey85

    insats

    Joined:
    Aug 27, 2008
    Messages:
    7
    Likes Received:
    0
    YES!



    I finally found out how to disable the Toredo Tunneling Pseudo interface and it has stopped dropping the connection!



    It's been explained earlier, but I'll do it again for new users:



    Go to the device manager

    Show all devices (or show hidden devices)

    Go down to network devices

    Find Toredo Tunneling Pseudo interface and deactivate it!
     
    insats, Aug 27, 2008
  13. huey85

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Insats:



    Many thanks for the update.
     
    WAW8, Aug 27, 2008
  14. huey85

    Nicosu

    Joined:
    Aug 29, 2008
    Messages:
    5
    Likes Received:
    0
    Cheers! I never figured where that pseudo thingy actually was.



    Well, I've tried the router fixes and now disabled this - let's see if it helps.
     
    Nicosu, Aug 29, 2008
  15. huey85

    Nicosu

    Joined:
    Aug 29, 2008
    Messages:
    5
    Likes Received:
    0
    Shortly after, very shortly after... it disconnected again:crazy:
     
    Nicosu, Aug 29, 2008
  16. huey85

    insats

    Joined:
    Aug 27, 2008
    Messages:
    7
    Likes Received:
    0


    I just got disconnected again as well. The odd thing is that it has worked flawlessly since I disabled the Teredo tunneling thing, right until now.



    Back to square one...



    The only thing I have done since I thought I had fixed it was to reset the MTU size on the router to 1500 because our 3D-printer had some network problems after I had reduced it to 1450 (or something like that). Maybe it's the combination of making the MTU size smaller and disabling the teredo interface..? I don't know anymore, and I just feel like getting a brand new laptop right now..
     
    insats, Aug 30, 2008
  17. huey85

    Nicosu

    Joined:
    Aug 29, 2008
    Messages:
    5
    Likes Received:
    0
    May I suggest we all mail Intel (http://supportmail.intel.com/scripts-emf/welcome.aspx?id=) and nag them to make a change ;)

    .. though I don't think that'll help :doze: even if hundreds did it



    damn these multibillion corporations





    *I just sent one using the form.

    In describing the problem I pasted this thread html and "PLEASE HELP US"
     
    Nicosu, Aug 31, 2008
  18. huey85

    insats

    Joined:
    Aug 27, 2008
    Messages:
    7
    Likes Received:
    0
    I reformatted my laptop and got a brand new wifi card but the problem remains! I just don't get it!
     
    insats, Sep 29, 2008
  19. huey85

    Rood

    Joined:
    Oct 7, 2008
    Messages:
    2
    Likes Received:
    0
    People, here is your solution, works 100%!!

    The issue with the WiFi adapter is caused by incompatible Vista driver, as the problem does not happen under Windows XP system. Previously, users have used two workarounds as a temporary solution - “XP Fix” which uses Intel PRO Wireless 3945ABG driver designed for Windows XP, or rollback and switch back to Microsoft driver comes with Vista for Intel PRO Wireless 3945ABG network card. However, these workarounds have an drawback and disadvantage that the Wireless network or LAN is not optimized for fastest possible speed, instead opt for lower reliable speed throughput, and also have poor radio signal level problem.



    Luckily, Dell has released a new updated driver supporting Intel PRO/Wireless 3945ABG Network Connection and Intel Wireless WiFi Link 4965AGN. The driver version 11.1.1.22 dated 08/08/2007 comes from provider Intel, is packaged as R164259 (11.1.1.3) - A05 - August 2007 release. It fixes the following bugs (changelog):



    * Addresses 3945ABG radio disable seen with some systems running with Bluetooth modules

    * Addresses 3945ABG radio disable seen in some 802.11a environments after Standby or Hibernate

    * Addresses installer upgrade behavior where Windows Vista Preferred Networks would be lost

    * Addresses installer interaction with InstallShield Update Manager causing an unwanted prompt during installation



    The new driver will likely to solve the Wireless cuts off problem in Vista. Download the driver version 11.1.1.22 from ftp://ftp.dell.com/network/R164259.EXE. It’s a Dell installer package, which should works on other brands too. Otherwise, simply extract the driver by using WinRAR and manually update the driver for the network card from Device Manager.



    Post your outcome. This should fix it!! :w00t:
     
    Rood, Oct 7, 2008
  20. huey85

    insats

    Joined:
    Aug 27, 2008
    Messages:
    7
    Likes Received:
    0


    That driver has already been mentioned in this thread and didn't solve it for me.
     
    insats, Oct 16, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.