wireless adhoc network won´t work (no ipv4 connectivity)

Discussion in 'Networking & Internet' started by spriter, May 1, 2009.

  1. spriter

    spriter

    Joined:
    May 1, 2009
    Messages:
    1
    Likes Received:
    0
    I have a curious problem with wireless adhoc connection on vista.





    A did all procedures to wireless connect two laptops running vista (dell inspiron 1525 and sony vio)



    the adhoc link is setup (so vista says so). All ip address are set (10.0.88.1 and 10.0.88.2) net mask 255.255.255.0. BUT ping does not work. I cat access the shared folder. The network map is ok. It show the two computers connect to a network.

    The first time i could access the public folders on sony laptop from the dell laptop, but not vice-versa. Vista asked por password. So i tried to disable network password protected sharing. After this the problem begin.





    So i tried to let dhcp configure the interfaces. The wireless card interface was configured with an ip address asigned by vista.

    Ping still does not work. Ipconfig report an ipv6 address. So i use ping -6 to force using ipv6. So it did work but just from dell to sony but not from sony to dell. No ping using ipv4 works. I try to disable ipv6 suport on both interfaces but it was useless.



    Does any one knows why i just ping one way, not the other in ipv6??? Why ipv4 configuration does not work??? IPv6 and IPV4 shouldn´t work together??



    And more importante. How does one make vista work with ipv4??







    Thanks in advance.
     
    spriter, May 1, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.