Why do I get 'Found New Hardware' when I boot windows Vista on my laptop?

Discussion in 'General Technical' started by cjrobertson1, Mar 6, 2012.

  1. cjrobertson1

    cjrobertson1

    Joined:
    Mar 4, 2012
    Messages:
    2
    Likes Received:
    0
    Every time Windows boots on my laptop, the Driver Sofware Installation icon appears in the system tray. On opening this, it is searching for drivers for an unknown device and bluetooth peripheral device. There are usually 4 bluetooth, and 2 unknowns involved. For each item the 'Found New Hardware' wizard pop-up appears with 3 options, none of which work at all. The only way I can carry on is by clicking the X on each. I have found the said devices in Device Manager in the 'Other Devices' sub folder with the error icon attached and have tried update driver, have even uninstall each of them, yet on reboot it all starts again. I've attached shots of the pop-ups. I'm at a loss as I've no idea what these devices could be, and it's starting to get rather annoying now.

    Found new hardware.JPG

    Blue Per Device.JPG

    Capture.JPG

    Capture2.JPG

    Capture3.JPG
     
    cjrobertson1, Mar 6, 2012
    #1
    1. Advertisements

  2. cjrobertson1

    clifford_cooley

    Joined:
    Sep 1, 2010
    Messages:
    242
    Likes Received:
    0
    Check Windows Update for optional components that need to be updated.

    You may need to setup windows update to look for optional updates before they will appear. Hopefully there will be an update listed that will resolve this issue.
     
    clifford_cooley, Mar 7, 2012
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.