Vista Won't Sleep Properly

Discussion in 'General Technical' started by kingofnexus, Mar 17, 2008.

  1. kingofnexus

    kingofnexus

    Joined:
    Aug 1, 2006
    Messages:
    1,024
    Likes Received:
    0
    Location:
    England
    Vista not sleeping properly? Won't go to sleep? Won't stay asleep? This is the topic for you!



    Nearly all sleep problems are caused by devices that are set to be able to wake the computer back up again.They can wake your computer instantly, randomly, or can cause your computer not to fully enter sleep mode and even cause it never to wake up. If you have any problems similar to the ones described then the following could be your cure.



    Advanced Users: Check the system event log. The "power-troubleshooter" source will tell you what woke it up out of sleep. If it says "Wake Source: Unknown" Its most likely to do with step 3.



    1) Disable Vista's multimedia sharing option from restricting sleep:



    Type 'power options' in the start menu and press enter->Choose 'Balanced' -> 'Change plan settings' (for the chosen power plan) -> 'Change advanced power settings' -> Scroll down to 'Multimedia settings' -> Choose 'Allow the computer to sleep'



    2) Prevent Devices from being able to wake your computer.



    Type 'device manager' in the start menu and press enter



    -> Expand 'Keyboards' -> Right click 'properties' on your keyboard -> 'Power Management' tab -> Deselect 'Allow this device to wake the computer' -> OK



    -> Expand 'Mice and other pointing devices' -> Right click 'properties' on yourmouse -> 'Power Management' tab -> Deselect 'Allow this device to wake the computer' -> OK



    -> Expand 'Network Adapter' -> Right click 'properties' on yournetwork adapter-> 'Power Management' tab -> Deselect 'Allow this device to wake the computer' -> OK -> Repeat on all availablke network adapters



    -> Expand 'Universal Serial Bus controllers' -> Right click 'properties' onone ofthem-> Check for a 'Power Management' tab -> Deselect 'Allow this device to wake the computer' If power mangement tab is available -> OK -> Check all devices in the list, usually there isn't any with a power management tab but some devices do.



    3) Disable a hidden network ability that is set to wake your computer.



    Type 'Network and Sharing center' in the start menu and press enter -> On the left task pane choose 'Manage network connections' -> Right click your current network adapter and choose 'properties' -> In the networking tab under the name of the network adapter choose 'configure' -> 'Advanced' tab -> Wake up capabilities (or similar)-> In the 'value' drop down box select 'none' or 'disabled'. -> Repeat on any other network adapters. If the setting is missing move onto another network adapter.



    4) Check that there is no devices that are set to be able to wake your computer.



    Type in start menu 'cmd', right click the programand 'run as administrator' -> Type into command prompt 'powercfg -devicequery wake_armed' (without quotes) and press enter. If any device is listed go back into device manager (type it into start menu) and locate the device -> Right click 'properties' -> 'Power Management' -> Deselect 'Allow this device to wake the computer' -> OK



    5) Put your computer to sleep. Everything should work exactly how its supposed to. To wake your computer back up press the main power button on your computer.



    6) If you require a device to be able to wake your computer (i.e keyboard) simply go back into device manager and enable it. Put your computer back to sleep again to make sure that the device isn't causing any problems. Its best to disable everything first and turn devices back on one at a time which you require so that you identify any problems.
     
    kingofnexus, Mar 17, 2008
    #1
    1. Advertisements

  2. kingofnexus

    jahaova

    Joined:
    Jun 17, 2008
    Messages:
    1
    Likes Received:
    0
    :D I registered just so I could give you my thanks for this excellent guide! After doing some reading and trying various fixes, step 3 was the one that finally put my computer to sleep on its own. Thank you again!!
     
    jahaova, Jun 17, 2008
    #2
    1. Advertisements

  3. kingofnexus

    harro112

    Joined:
    Jun 20, 2008
    Messages:
    1
    Likes Received:
    0
    The above steps did help; i can hear the HDD start up again when i hit the power button but i get *no display*, just a black screen - the monitor remains on standby and if i turn it off then on again i get "no signal". my video card is geforce 9600GT.
     
    harro112, Jun 20, 2008
    #3
  4. kingofnexus

    kingofnexus

    Joined:
    Aug 1, 2006
    Messages:
    1,024
    Likes Received:
    0
    Location:
    England
    Its most likely a driver issue - are you using the latest nvidia drivers for your card?



    http://www.nvidia.com/Download/index.aspx?lang=en-us



    I'm also aware of an issue where the screen will stay black with no signal for upwards of 2 minutes before a display signal comes to life. As of now I don't know a solution for it.
     
    kingofnexus, Jun 20, 2008
    #4
  5. kingofnexus

    dennis-96gt

    Joined:
    Oct 27, 2008
    Messages:
    13
    Likes Received:
    0
    this was one of the reasons i registered because it didnt work right thank you
     
    dennis-96gt, Oct 27, 2008
    #5
  6. kingofnexus

    djdj

    Joined:
    Feb 8, 2009
    Messages:
    1
    Likes Received:
    0
    I too registered just so I could post.

    The above information is amazingly invaluable. While it didn't solve my problem directly, it did help get me pointed in the right direction. I didn't know about the powercfg utility... pretty cool stuff.

    I too am running an ASUS SLI board, AMD Athlon 64 processor, and my copy of Vista x64 just wouldn't go to sleep. I even wrotea little utility to help me track how long Windows thought the computer was idle (go to www.maxoutput.com, click Idle Clock to download; it's freeware) and was eventually able to narrow the problem down to the Marvell network adapter on my board. Turning off the power-related features wasn't enough; I had to entirely disable it in the BIOS(it wasn't being used). Andmy computer can now sleep.

    I posted a lengthy description of the process of diagnosing the problem on my blog too. http://doubledeej.blogspot.com/2009/02/vista-wont-sleep.html

    Good luck to anyone else with this problem, and thanks for the awesome information!
     
    djdj, Feb 8, 2009
    #6
  7. kingofnexus

    cpemma

    Joined:
    Feb 18, 2008
    Messages:
    5
    Likes Received:
    0
    My system won't stay asleep for more than a second if the printer power is switched off when I attempt to put it to sleep. Printer is a HP Laserjet 1300 connected by USB.



    Once asleep it's no problem turning peripherals off, I have an energy-saving device that automatically turns off power to printer, monitor and speakers when the main system is asleep and so drawing little current.
     
    cpemma, Feb 20, 2009
    #7
  8. kingofnexus

    jmccoid

    Joined:
    Mar 15, 2009
    Messages:
    1
    Likes Received:
    0
    I'm running Vista 64 and I have all my power options set to NOT put the computer to sleep; but randomly (not always) when my screen saver is on for a while, it goes to sleep and won't wake up without a hard reboot. Is there any reason why it would go to sleep on it's own without it set to do so?
     
    jmccoid, Mar 15, 2009
    #8
  9. kingofnexus

    BugMeNot

    Joined:
    Nov 12, 2006
    Messages:
    9
    Likes Received:
    0
    My Vista Business 64bit didn't sleep before I unchecked in Device Manager -> Mouse -> Right Click -> Properties -> Power Management -> "Allow this device to device up the computer" :)
     
    BugMeNot, Jul 6, 2009
    #9
  10. kingofnexus

    nic42

    Joined:
    Jul 7, 2009
    Messages:
    1
    Likes Received:
    0
    I have tried everything mentioned above and windows does not seem to attempt to sleep at the specified interval with no human activity.



    The computer will sleep when I click the sleep option on the power menu but it doesnt sleep automatically even though I am using balanced power and have a 1hr sleep time.
     
    nic42, Jul 7, 2009
    #10
  11. kingofnexus

    everybest

    Joined:
    Sep 5, 2009
    Messages:
    2
    Likes Received:
    0
    I use to put my computer to sleep to bring my laptop from work to home or elsewhere, and I'd find my bag heating up because my laptop randomly started up again. I started shutting the computer off and again, I'd find the laptop on randomly. Could this solve my problem? I've become use to not using my laptop battery at all and keeping that completely separate so my computer can't turn on, overheat and shut itself off again.
     
    everybest, Sep 5, 2009
    #11
  12. kingofnexus

    weed4all

    Joined:
    Sep 7, 2009
    Messages:
    1
    Likes Received:
    0
    Tnx kingofnexus! Step 1 solved for me! Cheers!
     
    weed4all, Sep 7, 2009
    #12
  13. kingofnexus

    swishalab

    Joined:
    Jan 23, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks, YOU ARE A BEAST! That's a good thing, to let you know!
     
    swishalab, Jan 23, 2010
    #13
  14. kingofnexus

    kristain

    Joined:
    Mar 17, 2010
    Messages:
    21
    Likes Received:
    0
    you check all settings.
     
    kristain, May 28, 2010
    #14
  15. kingofnexus

    sparkybhoy

    Joined:
    Aug 15, 2011
    Messages:
    1
    Likes Received:
    0
    Step 1 worked for me, couldn't do step 2 as I don't have the power management tab for the devices?

    I'm happy now though :)
     
    sparkybhoy, Aug 15, 2011
    #15
  16. kingofnexus

    cimengo

    Joined:
    Dec 3, 2011
    Messages:
    4
    Likes Received:
    0
    Once asleep it's no problem turning peripherals off, I have an energy-saving device that automatically turns off power to printer, monitor and speakers when the main system is asleep and so drawing little current.
     
    cimengo, Dec 11, 2011
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.