Vista does not sleep properly. Wakes up immediately.

Discussion in 'General Technical' started by kamidan, Feb 3, 2007.

  1. kamidan

    kamidan

    Joined:
    Feb 3, 2007
    Messages:
    1
    Likes Received:
    0
    [Solved] Vista does not sleep properly. Wakes up immediately.

    Hello,

    Im wondering if somone could help me sort out this problem.....

    When I tell Vista Home Premium edition to go to sleep, it powers down and everything shuts down like it should but then it immediately (within 2 or 3 seconds at most) wakes up by itself.

    I have turned off the ability for the keyboard and or mouse to wakeup vista from sleep but that didn't help anything.

    I'd appreciate it if anyone here knows something and could let me in on it because the sleep function seems very usefull for quick starting up my comptuer.

    Thanks,
     
    kamidan, Feb 3, 2007
    #1
    1. Advertisements

  2. kamidan

    Nypyren

    Joined:
    Feb 4, 2007
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    I have this problem on an NVIDIA nForce4 motherboard while using the onboard ethernet (incoming data wakes the computer up whether wake-on-LAN is enabled or not). Here's what I did to fix it:

    - Go into the device manager and find the ethernet card.

    - Right click on it and go to Properties. Find the "Power Management" tab.

    - UNCHECK all checkboxes in that tab, even the "Allow the computer to turn off this device to save power." It makes no sense, but this is what fixes it for me.

    Depending on what hardware you have this might fix your problem.
     
    Nypyren, Feb 4, 2007
    #2
    1. Advertisements

  3. kamidan

    oddlike7

    Joined:
    Feb 5, 2007
    Messages:
    11
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    If I had to guess, I'd say it is an incompatibility between your ACPI settings in your system BIOS, and the new Hybrid Sleep mode in Vista.

    Try right clicking on your desktop, then select "Personalize".

    Then click on "Screen Saver".

    Select the "Change Power Settings" link.

    On the next screen you'll see one of three power options selected. Click the "Change Plan Settings" link underneath the one you have selected.

    And finally, click on the "Change Advanced Power Settings" link.

    The fourth heading down should read "Sleep". Click the plus on it, and then the plus for "Allow hybrid sleep". Then turn the setting to off.

    I'm pretty sure this method doesn't even require a reboot, so at this point you can test it. If still no luck, I'd look into updating your system BIOS. Consult your computer manufacturer for more details if neccesary.

    GOOD LUCK!
     
    oddlike7, Feb 5, 2007
    #3
  4. kamidan

    theminhb

    Joined:
    Feb 5, 2007
    Messages:
    6
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    I tried turning off hybrid sleep on my pc but it will not automatically go to sleep at the default 20 minutes. The monitor will not turn off either in 15 minutes. I can hit the button on the keyboard and it goes to sleep fine, hit it again and its awake, produces a Critical Event though.

    Is there anything else that might be causing the Power Settings not to work?

    Windows Vista™ Home Premium
    Version 6.0.6000 Build 6000
    HP-Pavilion a1730n
    AMD Athlon™ 64 X2 Dual Core Processor 5000+, 2600 Mhz
    AUSUTek Model NODUSM3
    Chipset: GeForce 6150 / nForce 410/430 MCP
    Phoenix Technologies, LTD 5.04, 12/15/2006
    Physical Memory 2GB


    this just in... I went into the event viewer and here is what I found. What happened here is I rebooted my machine and walked away for awhile. When I came back the system was sleeping, came awake after moving the mouse but it was at the logon screen. Rebooted but never logged on. So it sleeps fine that way. But here in the event image you can see I woke it up and logged in on 2/5 at 8:23 PM the description below says it happened on 2/6 its Feb 5th today.

    [​IMG]
     
    theminhb, Feb 5, 2007
    #4
  5. kamidan

    oddlike7

    Joined:
    Feb 5, 2007
    Messages:
    11
    Likes Received:
    0
    oddlike7, Feb 6, 2007
    #5
  6. kamidan

    retexan599

    Joined:
    Jun 17, 2007
    Messages:
    8
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    <P class=MsoNormal style="MARGIN: 0in 0in 10pt 0.25in"><SPAN style="FONT-SIZE: 12pt; LINE-HEIGHT: 115%; FONT-FAMILY: 'Comic Sans MS'">I also have similar Vista sleep problems.
    Example:
    A) After pressing the ‘half moon’ keyboard sleep button:
    a) The monitor screen blanked out, then came back on in five seconds; no
    power down.
    b) Tower power button stayed blue.
    B) Pressing the sleep button a 2nd time blanked the screen and powered down
    the hard drive, but not the fans; tower power button turned amber
    C) Neither space bar nor mouse awakens system at that point
    D) To recover had to turn off the computer at the tower power button and
    restart.
    E) After getting the normal HP boot screen, got the black Windows Error
    Screen "Windows did not shut down successfully" which counted down and segued to the log in screen.
    F) Same effect if invoking sleep from Start ‘Power’ button.

    This behavior is repeatable; the first invocation of Sleep causes the screen
    to go off and on, but Sleep does not continue, and things work normally. A 2nd sleep invocation freezes the system in a kind of suspended animation. At times in my experimenting, I<SPAN style="mso-spacerun: yes"></SPAN>got the blue screen: "Stop: 0x00008086", but that has not been repeatable.

    Things I have tried to circumvent the problem:
    - unchecked "Allow this device to wake the computer" for my Network Adapter
    Power Management (no help)
    -verified that my Nvidia graphics card has its latest driver

    It also appears that if the system is put to sleep by the power option, it
    will also not reawaken from the keyboard or mouse; requires total power
    shutdown and restart.

    Have looked around for other solutions as you did, and found numerous
    references to sleep and power option problems, but no good solutions yet.
    For the time being, I am leaving the system running. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" /><o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 10pt 0.25in"><SPAN style="FONT-SIZE: 12pt; LINE-HEIGHT: 115%; FONT-FAMILY: 'Comic Sans MS'">----------------------------------------------------------<SPAN style="mso-spacerun: yes"> </SPAN><o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 10pt 0.25in"><SPAN style="FONT-SIZE: 12pt; LINE-HEIGHT: 115%; FONT-FAMILY: 'Comic Sans MS'">HP Pavilion d4890y desktop.....Intel Core 2 Duo processor E6420 (2.13GHz) ....2GB DDR2-667MHz dual channel SDRAM (2x1024).....250GB 7200 rpm SATA 3 GB/s hard drive.....256MB NVIDIA GeForce 7500LE graphics card.....HP w2207 22-inch Widescreen Flat-Panel Monitor.....Power supply 350 watts.....OEM Vista Home Premium.....Norton Internet Security 2007.....Standard wired keyboard and mouse<o:p></o:p></SPAN>
     
    retexan599, Jun 20, 2007
    #6
  7. kamidan

    retexan599

    Joined:
    Jun 17, 2007
    Messages:
    8
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    <P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">I think I have finally resolved my Vista sleep problem. My solution path was: <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" /><o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">
    -my HP Pavilion Vista system did sleep properly between May 25th (when I bought it) and June 13th; after that it began either not going to sleep or not waking from sleep.<o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">
    -on June 13th I had attempted to install software to run my HP Scanjet 3970 from a CD in drive E: I thought I had verified that the hardware and software would run on Vista, but evidently I was wrong; the scanner software appeared to partially install, but not completely; I subsequently uninstalled the programs.<o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">
    -I realized later that one artifact of the abortive installation remained, a reference to a program called zzzhpsetup.exe<o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">
    -I found it in the list of msconfig startup tab items. After I unchecked it, and did a reboot, the sleep function started to work ok.<o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">
    -zzzhpsetup did not show up in a full system search. Its msconfig Startup Command column showed E:\Setup.exe and referenced HKLM\SOFTWARE\Windows\CurrentVersion\Run in the registry; however, there is no recognizable item for zzzhpsetup in RegEdit. Google searches reveal almost nothing about such a program, although it seems to show up in peoples' HJT logs. I will just leave this item unchecked in the msconfig startup list. I would like to remove it from the listing altogether, but have not found a way to do this (since it does not show up in the registry). <o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'"><o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">-At this point, I have returned most of my Power Save options to the default values and the machine is sleep and waking normally. Obviously I don't have a cause and effect conclusion that zzzhpsetup was the source of the sleep problem, but on circumstantial evidence, it seems likely. <o:p></o:p></SPAN><P class=MsoNormal style="MARGIN: 0in 0in 0pt; LINE-HEIGHT: normal"><SPAN style="FONT-SIZE: 12pt; FONT-FAMILY: 'Times New Roman','serif'; mso-fareast-font-family: 'Times New Roman'">
    Thoughts from anyone would be welcomed. <o:p></o:p></SPAN>
     
    retexan599, Jun 26, 2007
    #7
  8. kamidan

    Fungi008

    Joined:
    Nov 12, 2007
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    I had the same problem: After choosing sleep, Vista would reanimate on its own 1 to 10 seconds later. Annoying!



    For me the trick was to realize that perhaps something was waking the computer up – and then to tell Vista to ignore it. It was both my (1) mouse and (2) Vista's dumb multimedia sharing option.



    Mouse: Easy solution (often posted elsewhere). Shut it up. Do this:

    Control Panel -> Device Manager -> Mice -> Right-click your specific mouse -> Properties -> Power Management tab -> uncheck "Allow this device to wake the computer"



    Vista's dumb multimedia sharing option: More complex (and I don't think anyone else has posted it). Do this:

    Control Panel -> Power Options -> If "High Performance" is selected, choose something else, like "Balanced" (I don't know why this works) -> Change plan settings (for the chosen power plan) -> Change advanced power settings -> Scroll down to Multimedia settings -> Choose "Allow the computer to sleep"



    My, won't your computer feel much more rested, and your power bill will go down to boot.
     
    Fungi008, Nov 12, 2007
    #8
  9. kamidan

    kingofnexus

    Joined:
    Aug 1, 2006
    Messages:
    1,024
    Likes Received:
    0
    Location:
    England
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    Fungi008, you are nothing short of a God!

    Thanks so much for your post, its fixed my issues with sleep entirely! No longer does the computer fans continue to spin, but it now doesn't ever come back on again (it used to decide 50% of the time that it doesn't want to go to sleep, and when it did want to go to sleep, the fans continued to whir).
     
    kingofnexus, Nov 13, 2007
    #9
  10. kamidan

    boisedubliner

    Joined:
    Feb 13, 2008
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    thanks<TABLE cellSpacing=0 cellPadding=0 width="100%"><TBODY><TR><TD class=SmallTxt width="80%">

    <DIV id=_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName_SimpleMenuDivLayer onmouseover="InstantASP_OpenMenuMouseOver('_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName','_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName_SimpleMenuDivLayer','<table width=100% class=PanelBar_OuterTable cellspacing=0 cellpadding=0><tr><td><table width=100% cellspacing=1 cellpadding=7><tr><td class=TableCell_Light>View Member\'s Profile</tr><tr><td class=TableCell_Light>Add to Buddy List</tr><tr><td class=TableCell_Light><a href=__doPostBack(\'butSendPrivateMessage\',\'1219\'); onmouseover=\'window.status=window.location;return true;\'; onmouseout=window.status=\'\';return true; Class=\'SmlLinks\' Title=\'Send Private Message\'>Send Private Message</a></tr><tr><td class=TableCell_Light><a href=__doPostBack(\'butSendEmail\',\'1219\'); onmouseover=\'window.status=window.location;return true;\'; onmouseout=window.status=\'\';return true; Class=\'SmlLinks\' Title=\'Send Email To Member\'>Send Email To Member</a></tr><tr><td class=TableCell_Light><a href=__doPostBack(\'butShowMemberPosts\',\'1219\'); onmouseover=\'window.status=window.location;return true;\'; onmouseout=window.status=\'\';return true; Class=\'SmlLinks\' Title=\'Find All Member\s Posts\'>Find All Member\'s Posts</a></tr></td></tr></table></td></tr></table>','165px');" style="DISPLAY: inline" onclick="InstantASP_OpenMenu('_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName','_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName_SimpleMenuDivLayer','<table width=100% class=PanelBar_OuterTable cellspacing=0 cellpadding=0><tr><td><table width=100% cellspacing=1 cellpadding=7><tr><td class=TableCell_Light>View Member\'s Profile</tr><tr><td class=TableCell_Light>Add to Buddy List</tr><tr><td class=TableCell_Light><a href=__doPostBack(\'butSendPrivateMessage\',\'1219\'); onmouseover=\'window.status=window.location;return true;\'; onmouseout=window.status=\'\';return true; Class=\'SmlLinks\' Title=\'Send Private Message\'>Send Private Message</a></tr><tr><td class=TableCell_Light><a href=__doPostBack(\'butSendEmail\',\'1219\'); onmouseover=\'window.status=window.location;return true;\'; onmouseout=window.status=\'\';return true; Class=\'SmlLinks\' Title=\'Send Email To Member\'>Send Email To Member</a></tr><tr><td class=TableCell_Light><a href=__doPostBack(\'butShowMemberPosts\',\'1219\'); onmouseover=\'window.status=window.location;return true;\'; onmouseout=window.status=\'\';return true; Class=\'SmlLinks\' Title=\'Find All Member\s Posts\'>Find All Member\'s Posts</a></tr></td></tr></table></td></tr></table>','165px');">Nypyren,</DIV>

    <DIV onmouseover="InstantASP_OpenMenuMouseOver('_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName','_ctl1_ctlTopic_ctlPanelBar_ctlTopicsRepeater__ctl2_smAuthorName_SimpleMenuDivLayer','<table width=100% class=PanelBar_OuterTable cellspacing=0 cellpadding=0><tr><td><table width=100% cellspacing=1 cellpadding=7><tr><td class=TableCell_Light>View Member\'s Profile</tr><tr><td class=TableCell_Light><a href=BuddyIgnoreLi
     
    boisedubliner, Feb 13, 2008
    #10
  11. kamidan

    eyalco

    Joined:
    Aug 21, 2008
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    it was hepfull. thank you
     
    eyalco, Aug 21, 2008
    #11
  12. kamidan

    kosacik

    Joined:
    Oct 16, 2008
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    I tried everything, i thougt...

    I shutted down all adapters, network cards, soundcard...

    But i have forget to check multimedia settings in power options... so when i turned sharing my data on, with notebook, pc does not wanted to sleep.



    great advice, thank you
     
    kosacik, Oct 16, 2008
    #12
  13. kamidan

    ansarico

    Joined:
    Feb 17, 2009
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    Hi,



    I also fixed the same issue by turning the switch for the wireless off. It also worked after disabling the power management checkboxes on the device manager for the wireless network adapter.



    Thanks!!
     
    ansarico, Feb 17, 2009
    #13
  14. kamidan

    witness

    Joined:
    May 15, 2009
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    I could not find "ethernet card"
     
    witness, May 15, 2009
    #14
  15. kamidan

    throwaway6936

    Joined:
    Jul 25, 2010
    Messages:
    1
    Likes Received:
    0
    RE: [Solved] Vista does not sleep properly. Wakes up immediately.

    That fixed it. Many thanks good sir.
     
    throwaway6936, Jul 25, 2010
    #15
  16. kamidan

    weelmin

    Joined:
    Oct 7, 2012
    Messages:
    1
    Likes Received:
    0
    weelmin

    My pc had the same problem and after trying everything I had given up. then recently the pc would not power up properly every time . It would run seemingly ok when it did power up it was the initial startup that was the problem. I had to switch it of at the main switch on the psu and on again before it would fire up properly . After reading a few geek searches it looked pretty certain it was a failing psu .
    Now ...heres the good part .
    After renewing the psu the pc now not only STARTS PROPERLY and FASTER
    But it also SLEEPS PROPERLY!...........GREAT!

    In my case the sleep problem. was the initial signs of a failing psu.
    So if trying in vain try another psu it only takes a few minutes.
     
    weelmin, Oct 7, 2012
    #16
  17. kamidan

    TerryW

    Joined:
    Jan 19, 2014
    Messages:
    1
    Likes Received:
    0
    Thanks fungi...after 5 yrs with this machine it started to play up. Your tip sorted it out.
     
    TerryW, Jan 19, 2014
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.