Vista does not show External Hard Drive connected through USB (USB 2.0 TO IDE)

Discussion in 'General Technical' started by toseef, Oct 29, 2010.

  1. toseef

    toseef

    Joined:
    Oct 29, 2010
    Messages:
    2
    Likes Received:
    0
    I have formatted and partitioned Maxtor 30 GB HD and want to use it as an external extended backup storage device. I have set the Jumper to 'Master' and format type is NTFS. The HD works perfectly with my old PC (Win XP) as an external drive through USB. But when I attach it with my new PC (Vista Home Premium), the HD is shown in 'Device Manager' only and no where in 'My Computer' or in 'Disk Management'. I have tried different USB ports on my new PC but I couldn't be able to get it recognized by Vista yet. I have searched the internet and most of the solutions say about changing of drive letters and reformatting but my problem is that external hard drive does not appear in 'Disk Management' section at all in any form. Any help in this regard will be much appreciated.
     
    toseef, Oct 29, 2010
    #1
    1. Advertisements

  2. toseef

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Generally speaking, a single drive does not need to be jumpered. There are exceptions and yours might be one of the few. Try connecing it without the jumper and see what happens. Other than that, don't know what to tell you.
     
    WAW8, Oct 30, 2010
    #2
    1. Advertisements

  3. toseef

    toseef

    Joined:
    Oct 29, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks for the reply. I have already used various options of jumper setting even tried without jumper but no option went well.
     
    toseef, Oct 30, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.