Sound Blaster LIVE sound card help

Discussion in 'General Technical' started by kylerpointer, Apr 7, 2007.

  1. kylerpointer

    kylerpointer

    Joined:
    Apr 4, 2007
    Messages:
    10
    Likes Received:
    0
    Therer is no SBLive Vista driver available, and Vista cannot even finda sound card on my PC. People with SBLive cards, what did you do? Thanks!
     
    kylerpointer, Apr 7, 2007
    #1
    1. Advertisements

  2. kylerpointer

    g2f

    Joined:
    Apr 1, 2007
    Messages:
    8
    Likes Received:
    0
    you want the kx audio driver mate just google it will only give 2speaker +subwoofer sound though but better than nowt until creative cum up with a fix..........
     
    g2f, Apr 7, 2007
    #2
    1. Advertisements

  3. kylerpointer

    doghucat

    Joined:
    Jun 15, 2006
    Messages:
    50
    Likes Received:
    0
    They do not plan on nay new drivers for that card i had the same issue but after some research i went out and purchased the Bluegears b-Enspirer sound card that has Vista driver support and does it sound great with Vista very happy with my upgrade
     
    doghucat, Apr 7, 2007
    #3
  4. kylerpointer

    kylerpointer

    Joined:
    Apr 4, 2007
    Messages:
    10
    Likes Received:
    0
    ive downloaded the driver, but it cant even find my SBLive card...
     
    kylerpointer, Apr 7, 2007
    #4
  5. kylerpointer

    kylerpointer

    Joined:
    Apr 4, 2007
    Messages:
    10
    Likes Received:
    0
    ok, i go to sound, playback, andall it finds is a VIA AC'97 enhanced audia controller which isnt my SBLive card... When i play music the visualizer is bouncing up and down as if sounds were playing, but nothing is coming out of my speakers
     
    kylerpointer, Apr 7, 2007
    #5
  6. kylerpointer

    g2f

    Joined:
    Apr 1, 2007
    Messages:
    8
    Likes Received:
    0
    ave u got seperate speakers wired into ure onboard soundcard? if not thats why u no sound as for the drivers not finding ure card u could try disable ac97 in bios reboot and try kx drivers again or try these drivers, NGO Creative Modded Driver for SB Live! (http://www.ngohq.com) good luck!!!!!
     
    g2f, Apr 8, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.