Programmes (games) can't access AppData suddenly

Discussion in 'General Technical' started by Mataeus, Jun 16, 2009.

  1. Mataeus

    Mataeus

    Joined:
    Jun 16, 2009
    Messages:
    2
    Likes Received:
    0
    Hey, I'm new here and have spent the last day googeling my problem with no success.

    So first, the problem:

    Without any (conscious) changes to anything on my part, all of a sudden games (I say games and not programmes becuase that's what I mostly use my PC for) have trouble using the AppData junctions.

    This started a couple of weeks ago; it was before installing Vista SP2, and the problem persists after installing SP2 as well.

    Some examples of my problem:

    When running Bethesda games such as Morrowind, Oblivion and Fallout 3, in the launch splash screen where you can select different mods to run by clicking on the Data Files button (as is the norm in Bethesda games), I cannot keep the changes I make.

    Oblivion example:

    After ticking the various boxes to include various mods in my game, I press save but get an error message saying "Access to Path: 'C:\Users\Mataeus\AppData\Local\Oblivion\plugins.txt' is denied."

    However, if I go to that location and edit the text file myself and press save, no problems and my mods are active!

    This is just one example, every single game I play that tries to write content through the AppData junctions has just suddenly stopped being able to do so! Although I understand they are not real folders as such I have checked the security settings and I have full access under Users, but that is not really the problem I guess - the programmes that need to access these locations and files can't!

    Has anybody heard of anything similar?

    Here's my DXDiag report if that's any use to you (I am aware that I have both the external and the internal soundcard running, this is because I use Skype when playing games to chat and I like the Skype chat to come through the headset from my internal card and all the game sounds to come through the speakers. I have tried disabling either / both and rebooting but it makes no difference for this particular problem, not that I would expect it to!):



    ------------------

    System Information

    ------------------

    Time of this report: 6/16/2009, 23:06:14

    Machine name: DEATH_MACHINE

    Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (6002.lh_sp2rtm.090410-1830)

    Language: English (Regional Setting: English)

    System Manufacturer: Packard Bell BV

    System Model: iPower X8640

    BIOS: Phoenix - AwardBIOS v6.00PG

    Processor: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (4 CPUs), ~2.4GHz

    Memory: 3326MB RAM

    Page File: 1286MB used, 5596MB available

    Windows Dir: C:\Windows

    DirectX Version: DirectX 10

    DX Setup Parameters: Not found

    DxDiag Version: 6.00.6001.18000 32bit Unicode



    ------------

    DxDiag Notes

    ------------

    Display Tab 1: No problems found.

    Sound Tab 1: No problems found.

    Sound Tab 2: No problems found.

    Sound Tab 3: No problems found.

    Input Tab: No problems found.



    --------------------

    DirectX Debug Levels

    --------------------

    Direct3D: 0/4 (retail)

    DirectDraw: 0/4 (retail)

    DirectInput: 0/5 (retail)

    DirectMusic: 0/5 (retail)

    DirectPlay: 0/9 (retail)

    DirectSound: 0/5 (retail)

    DirectShow: 0/6 (retail)



    ---------------

    Display Devices

    ---------------

    Card name: NVIDIA GeForce 9600 GS

    Manufacturer: NVIDIA

    Chip type: GeForce 9600 GS

    DAC type: Integrated RAMDAC

    Device Key: Enum\PCI\VEN_10DE&DEV_0623&SUBSYS_9420174B&REV_A1

    Display Memory: 2161 MB

    Dedicated Memory: 753 MB

    Shared Memory: 1407 MB

    Current Mode: 1680 x 1050 (32 bit) (60Hz)

    Monitor: SyncMaster T220/T220G,SyncMaster Magic T220/T220G(Digital)

    Driver Name: nvd3dum.dll,nvwgf2um.dll

    Driver Version: 7.15.0011.8250 (English)

    DDI Version: 10

    Driver Attributes: Final Retail

    Driver Date/Size: 3/28/2009 00:03:00, 6082560 bytes
     
    Mataeus, Jun 16, 2009
    #1
    1. Advertisements

  2. Mataeus

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Sorry, but the Mods that were hard-core gamers seem to have left and we're not equipped to do system debugging. All I can suggest is searching for an online forum for the games you're using and seeing if anyone there has encountered and solved the same problem.
     
    WAW8, Jun 17, 2009
    #2
    1. Advertisements

  3. Mataeus

    Mataeus

    Joined:
    Jun 16, 2009
    Messages:
    2
    Likes Received:
    0
    It's not a games issue though, that was just an example... The issue is that my programmes can't make changes to any files accessed through appdata! As you can imagine this is a HUGE problem.
     
    Mataeus, Aug 19, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.