Perpetual RED X icon (no globe); Updated Atheros Driver, No Internet connection, not even local

Discussion in 'Networking & Internet' started by NotDoing2Good, Jun 19, 2016.

  1. NotDoing2Good

    NotDoing2Good

    Joined:
    Jun 19, 2016
    Messages:
    1
    Likes Received:
    0
    Hello! Thank you for looking! I need great help here. My issue is (was) similar to people who only had "local only" network. I'll try to make this as concise as possible.

    *I am on mobile currently, seeing how my main machine can't connect.
    *Windows Vista SP2, G50-108NR Notebook PC
    *Atheros AR5007 802.11b/g WiFi Adapter

    I got a new router, you know, really fast: Netgear AC1900, Model C7000. My phone works just fine connecting!

    I try to connect to my PC. What I FIRST discover is that I can't connect to the Internet. At this point I only had Local Area connection. I couldn't communicate with the DNS server is what it said, I think. Like I said, I couldn't get on the internet. The "online" icon that usually had the Globe was blank, no red x or even yellow warning. My network was "unidentified"....

    Networks were visible, but I could not connect to mine. I had the password correct, I know I did. I even tried changing the WPA2 security settings (none worked).

    I think I tried everything to try to fix this up to this point.

    I then looked at HP to see if there was something wrong. The site said that the Wireless Adapter needed to be updated. So I trusted that. I downloaded the latest driver for my Wireless Adapter to my mobile device to transfer to my computer.

    "Atheros Wireless LAN Driver Version: 2.00 B Aug 25, 2010" for my "Atheros AR5007 802.11b/g WiFi Adapter". You can find the driver page here http://support.hp.com/us-en/drivers/selfservice/hp-g50-100-notebook-pc-series/3744116/model/3808632

    I go ahead and uninstall my old Atheros driver, which was the stock driver since I never had to bother with this in the past. Afterward, I run the downloaded driver update. I go through the process no problem and I am informed that it was installed successfully. I restart the computer, only to find my current problem: No connection whatsoever, not even local area. I cannot view ANY networks and the Red X is perpetual. Oddly enough, the Blue Radio signal (the physical button to turn the wifi on/off) was still blue.

    Of course I was peeved, and I didn't know what to do. I had tried other Atheros Driver updates before posting in these forums. I would download a hopeful driver update, uninstall the previous udpate, restart, then install the newly acquired update and restart again. I don't know how many times I did this, certainly more than ten. The problem still persists.

    Reverting back to the stock Atheros driver does not work. The problem still persists.

    I tried many tricks like 'netsh int ip reset reset' or whatever. Microsoft no longer supports Vista, so I can't get them to help me.

    I cannot afford a system restore and wipe all my info (tech. all that's wrong is I can't connect to the Internet, all my other stuff is fine).

    Please, help me if you think you can. Although you may have to explain things to me as if I were 12. I am not super tech savvy, but I am willing to get through this. I will try my best to be patient & understand anyone here, and I will try to elaborate more if requested.

    Thank you!
     
    NotDoing2Good, Jun 19, 2016
    #1
    1. Advertisements

  2. NotDoing2Good

    Stuart Grant

    Joined:
    Aug 21, 2016
    Messages:
    1
    Likes Received:
    0
    Hi, I have a similar problem, except my wireless light is orange. I can't see any replies, have you had any?
    Stuart
     
    Stuart Grant, Aug 21, 2016
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.