Multiple "Side by Side Configuration" errors.

Discussion in 'General Technical' started by wolfen420, Jul 8, 2010.

  1. wolfen420

    wolfen420

    Joined:
    Jul 8, 2010
    Messages:
    4
    Likes Received:
    0
    Hi there,



    I recently rebooted one day and I am now recieving errors like this on many programs (but not all)



    "[App path]

    The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail."



    Ive done some research, and it seems some can fix this, and some cant. Im hoping some one here can help me out. I already tried uninstalling, and reinstalling some of the problem apps, as well as every redistributable I can for the MSVC libraries. No luck.



    I cant even open the event viewer from the control panel. How ever I was able to get open by doing a search for the application and launching one of the 4 or 5 ones I found. I was able to track it down to a very specific winsxs dir. They are all the same. How ever I have no idea how to repair or find that file or what I am supposed to do there.



    Im fairly competent at computers, so if you need any further info from me I should be able to provide that.



    OS: Vista64 Ultimate with SP2



    -begging- Please help me. I dont want have to restore from a 4 month old backup (at least I have a backup haha)



    Edit: Here are a couple of the general info errors in the event viewer.

    ----------------

    Activation context generation failed for "C:\Program Files (x86)\Stardock\ObjectDockPlus2\Dock64.exe". Dependent Assembly Microsoft.VC90.DebugCRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.

    (mind you the exe is just one of many that is reported)

    ----------------



    And for a more odd one and the most recent and common that shows up



    Activation context generation failed for "C:\Windows\System32\TMM.dll". The setting http://schemas.microsoft.com/SMI/2005/WindowsSettings^dpiAware is not registered.

    ---------------



    FIXED: After some serious digging and snooping and associating and asking people. A friend said something that made it click "Something sounds like its not registered".



    So, this made me think of the registry. I searched the registry and found this

    ==========================

    Windows Registry Editor Version 5.00



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings]



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings\amd64_microsoft-windows-settings_31bf3856ad364e35_none_5e7b0013834d1c8b]



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings\amd64_microsoft-windows-settings_31bf3856ad364e35_none_5e7b0013834d1c8b\6.0.6000.16386]

    "targetNamespace"="http://schemas.microsoft.com/SMI/2005/WindowsSettings"



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings\amd64_microsoft-windows-settings_31bf3856ad364e35_none_5e7b0013834d1c8b\6.0.6000.16386\Settings]



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings\x86_microsoft-windows-settings_31bf3856ad364e35_none_025c648fcaefab55]



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings\x86_microsoft-windows-settings_31bf3856ad364e35_none_025c648fcaefab55\6.0.6000.16386]

    "targetNamespace"="http://schemas.microsoft.com/SMI/2005/WindowsSettings"



    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SMI\WinSxS Settings\x86_microsoft-windows-settings_31bf3856ad364e35_none_025c648fcaefab55\6.0.6000.16386\Settings]

    "disableTheming"="xsd:string"

    "dpiAware"="xsd:string"


    ==========================



    What I realized is the x86 version, under the key settings had a couple entries, where as the 64bit versions same settings folder is / was empty. So I made backups of the registry and a system restore point. Added the two lines to the 64 version and rebooted. Problem solved.
     
    wolfen420, Jul 8, 2010
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.