Load Lan Ethernet before Wireless??

Discussion in 'Drivers' started by rlkellenbenz, Aug 31, 2009.

  1. rlkellenbenz

    rlkellenbenz

    Joined:
    Aug 31, 2009
    Messages:
    2
    Likes Received:
    0
    <DIV style="BORDER-BOTTOM: #bbbbbb 1pt solid; BORDER-LEFT: #bbbbbb 1pt solid; PADDING-BOTTOM: 0in; PADDING-LEFT: 0in; PADDING-RIGHT: 0in; BACKGROUND: white; MARGIN-LEFT: -0.25in; BORDER-TOP: #bbbbbb 1pt solid; MARGIN-RIGHT: 0in; BORDER-RIGHT: #bbbbbb 1pt solid; PADDING-TOP: 0in; mso-element: para-border-div"><P style="PADDING-BOTTOM: 0in; LINE-HEIGHT: normal; TEXT-INDENT: -0.25in; MARGIN: 0in 0in 10pt 0.25in; PADDING-LEFT: 0in; PADDING-RIGHT: 0in; BACKGROUND: white; PADDING-TOP: 0in; tab-stops: list .5in" class=MsoNormal><SPAN style="FONT-FAMILY: Symbol; COLOR: black; FONT-SIZE: 10pt"><SPAN>·<SPAN style="FONT: 7pt 'Times New Roman'"> </SPAN></SPAN></SPAN><SPAN style="FONT-FAMILY: 'Verdana', 'sans-serif'; COLOR: black; FONT-SIZE: 8pt">I have a unique problem.I need to Vista to load my ethernet card before my wireless. A program I use loads the mac address of my wireless card first,then uses this mac address as the hardware id that the product key is controlled by. I've tried spoofing the mac address on the wireless card, but no matter what i do it doesn't register in my program. I am very familiar with spoofing and have done this numerous times in XP. I have done it through the registry and through the advanced settings on the adapter itself. Nothing works.

    I have given up on the spoofing, my lan card has the correct mac address. I just need to change the order in which Vista loads this device so that my wired ethernetloads first.

    Here's what I have tried so far.
    </SPAN></DIV><P style="MARGIN: 0in 0in 10pt" class=MsoNormal><SPAN style="LINE-HEIGHT: 115%; FONT-FAMILY: 'Verdana', 'sans-serif'; COLOR: black; FONT-SIZE: 8pt">I first tried by turning off the wireless in the front of the laptop. Rebooted the computer and my program still pulled the mac address from the wireless. Next disabled the wireless in the network manager and rebooted, now it works perfectly. The mac address from the wired ethernet shows up and the program works.

    Now i re-enabled the wireless and within minutes the mac adress changed back to the wireless in the program and the program wont work.

    The only way I can see this working is ifI can get the priority of the wired ethernet to be before the wireless.It seems like the priority is dynamicnot static.Is there a way to do this?I've been all over the internet searching but cannot find anything about this.

    I even went into the registry and added a valueof the IRQXXPriority, but that didn't work either.

    Help......</SPAN>
     
    rlkellenbenz, Aug 31, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.