Help me with Vista lag in games

Discussion in 'General Technical' started by George, Mar 28, 2007.

  1. George

    George

    Joined:
    Mar 28, 2007
    Messages:
    6
    Likes Received:
    0
    ok just got a new computer with vista on it and when i try to play world of warcraft it lags never has laged for me before anyone know the newest diver for 32bit processors??? i downloaded some but didn't really

    help any help please
     
    George, Mar 28, 2007
    #1
    1. Advertisements

  2. George

    cyclic

    Joined:
    Feb 20, 2007
    Messages:
    607
    Likes Received:
    0
    It would help if you posted some details ie; your PC spec, the version of Vista your ISP etc; There may be an external problem which has nothing to do with your PC but without details it's impossible to speculate.
     
    cyclic, Mar 28, 2007
    #2
    1. Advertisements

  3. George

    George

    Joined:
    Mar 28, 2007
    Messages:
    6
    Likes Received:
    0
    intel core 2 duo processor e6300



    Nivida geforce 7600gs 256 mb



    2gigd ram



    Windows vista home edition premium



    processor 4.8



    Ram 5.4



    graphics 4.7



    gaming graphics 4.8



    primary hard disk 5.5



    whats else is needed
     
    George, Mar 28, 2007
    #3
  4. George

    George

    Joined:
    Mar 28, 2007
    Messages:
    6
    Likes Received:
    0
    i have sbc internet



    norton anti virus i unistalled macfee
     
    George, Mar 29, 2007
    #4
  5. George

    siopao

    Joined:
    Sep 18, 2007
    Messages:
    1
    Likes Received:
    0
    bump... same problem.
     
    siopao, Sep 18, 2007
    #5
  6. George

    Jaycub990

    Joined:
    Aug 29, 2007
    Messages:
    13
    Likes Received:
    0
    Location:
    Ireland
    Hi George im not a gamer myself but i do have WOW for my son on a dell 4550 with Vista home premium 2.52Ghz 1Gb ram Ati graphics card 256mb and he thought the game played well with no lag and your specs are a lot higher and a much better graphics card.so i read on another forum that this could be down to your graphics card settings so give this a try

    This is the suggestion

    "un-needed settings such as Anti-Aliasing and Anisotropic. If you have any of those on, go and make sure their turned to off in your Nvidia display settings".
     
    Jaycub990, Sep 18, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.