File Permission Ownership difference b/w FireFox and Vista

Discussion in 'General Technical' started by excalibr, Feb 9, 2009.

  1. excalibr

    excalibr

    Joined:
    Feb 9, 2009
    Messages:
    2
    Likes Received:
    0
    Greetings,



    I have a network share setup b/w a Vista Ultimate x32 and XP machines. Using the XP machine, I open the Vista hosted share but found some files "missing", ie. even though they physically exist in the Vista machine, I simply cannot see them from XP.



    Turns out that these files are missing the EVERYONE in the File Permissions (right click file, properties, security).



    These are files downloaded using Firefox, and whether they are JPG, AVI, TXT, DOC, XLS they are all missing the EVERYONE permission.



    If I download the same files using Internet Explorer, the files get created with the EVERYONE permission.



    My current workarounds ... which none are desirable are this:



    - Use Internet Explorer



    - Add EVERYONE permission for each file manually (you have to do this one by one, can't select multiple files and perform bulk operation)



    - Use CMD line utilities like takeown and icacls



    Note this is a secure home network, and while file sharing using EVEYRONE isn't the safest way to do this, I can finetune this later. The key problem at hand is what I've described above.



    Appreciate any suggestions :) I'd be happy just to be able to get FireFox create files with the full permissions, same way IE does.



    Thanks, Excalibur
     
    excalibr, Feb 9, 2009
    #1
    1. Advertisements

  2. excalibr

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Are you by any chance downloading to different folders using FF than using IE?



    Standard permissions would dictate that files created in folder will inherit permissions from the folder itself. If the folders are different, and the permissions are different, that could explain the different file permissions.
     
    WAW8, Feb 10, 2009
    #2
    1. Advertisements

  3. excalibr

    excalibr

    Joined:
    Feb 9, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks for the response, but both FF and IE are downloading to the same folder, and that folder does have EVERYONE



    Unless FF and IE uses a different TEMPORARY folder to stage the downloads, then move it out to the final destination folder. In any case, I don't know where these temp folders are located.



    Excalibur
     
    excalibr, Feb 10, 2009
    #3
  4. excalibr

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    However, I don't think that's the problem because I just tried a test downloading files using FF and IE -- to the same folder -- and both files had the same security settings of "everyone".



    However, in checking the Advanced settings for security, I notice that the files (and the containing folder) are inheriting permissions from the root of the volume (in this case E:\) not from a parent folder.



    If it will let you, try having the files inherit permissions from the folder.
     
    WAW8, Feb 10, 2009
    #4
  5. excalibr

    ArJuna

    Joined:
    Mar 14, 2009
    Messages:
    1
    Likes Received:
    0


    Excalibur,



    You did a great job explaining the problem. I have the exact same problem on a brand new HP Pavillion dv9843 laptop with a fresh Vista x64 load on it. I spent 3 hours trying to figure this out and I came to the same conclucions. It is clearly a problem with Firefox and the way it handles downloads. IE7 permissions are taken from the parent directory in which you save the file and can be seen by others using the file share. Firefox does not.



    FIXED

    Firefox simply takes the permission of the temp folder and then moves the file to the save directory. This is the problem. I just fixed it by creating a new "TEMP" directory. In my case on another drive. I was wanting to do this anyway. I then added the "everyone" entry into the security permissions and then I changed the environment variables for both "TEMP" and "TMP" to point to this new directory. Now when I download a file in Firefox it immediate shows up in the share on my other computers. In fact I had a window open to the shared directory I saved in on a remote machine and just as I saved the file on the host machine the file instantly popped up on the remote machine. That is how it should work.

    I hope this helps. I imagine a lot of people are having this problem and Mozilla should have fixed this one already.



    ETA

    I would imagine you could simply edit the permissions of the default Temp directory and achieve the same result. I just wanted to move the temp directory anyway.
     
    ArJuna, Mar 14, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.