External Hard Drive does not mount

Discussion in 'General Technical' started by misslizzy, Jan 20, 2008.

  1. misslizzy

    misslizzy

    Joined:
    Jan 20, 2008
    Messages:
    2
    Likes Received:
    0
    I have an external hard drive that I was using on a mac. It was formatted to HFS and I used disc utility to format it to fat32. Then I connected it to my Vista PC and it does not show up under computer with my internal hd, ipod, etc. It only shows up in the "safely remove hardware" usb manager thing. How do I get it to show up so I can use it?
     
    misslizzy, Jan 20, 2008
    #1
    1. Advertisements

  2. misslizzy

    MafiaLord91

    Joined:
    Dec 29, 2006
    Messages:
    142
    Likes Received:
    0
    Go to control panel. Administrative tools (should be in the classic style control panel). Click Computer Managment. Then click on disk management. You should now see all volumes. Remove your ipod and other removable media. Now since Vista runs on NTFS this part is easy since you know your external is formatted with fat32. Select the drive and right click. You should get a menu with an option to Change Drive Letter and Paths. Click on Change drive letter and paths. Now click change and change it to something like Z. This should work. If not try connecting the drive to a rear USB port.
     
    MafiaLord91, Jan 20, 2008
    #2
    1. Advertisements

  3. misslizzy

    misslizzy

    Joined:
    Jan 20, 2008
    Messages:
    2
    Likes Received:
    0
    Thanks for the response. It mounts now but the only thing is I don't want to format it to NTFS because I would because I will be using it on other operating systems. I would like to format it to FAT32 but there is the 32 gb limitation and it' a 500 gb hard drive.
     
    misslizzy, Jan 20, 2008
    #3
  4. misslizzy

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    You're right, FAT32 does have the 32GB limitation; however, it also has the limitation of no files larger than around 4GB. If you're going to use this external drive with a number of machines, and you don't want to use NTFS, FAT32 is the best choice.
     
    WAW8, Jan 21, 2008
    #4
  5. misslizzy

    mark7201

    Joined:
    Feb 25, 2008
    Messages:
    1
    Likes Received:
    0
    i ran into this same problem. when using disk utility to format as fat32, mac osx defaults to guid partition table, you'll have to go to disk utility, select your disk (not the volume), go to the partition tab and select "1 partition" under volume scheme, in the options menu select "master boot record", ok and then apply. should be good to go after that!
     
    mark7201, Feb 25, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.