Disable Data Executive Protection for Thief: Deadly Shadows?

Discussion in 'Gaming Support' started by thewhiteronin, Jul 29, 2011.

  1. thewhiteronin

    thewhiteronin

    Joined:
    Jul 29, 2011
    Messages:
    2
    Likes Received:
    0
    I have Windows Vista Home Premium 32-bit and I tried to play Thief 3 on it. It gives me a Data Execution Prevention (DEP). I looked deeper into the issue and I found out I could disable DEP with a simple phrase on Command Prompt: "bcdedit /set nx AlwaysOff" (Minus the quotes if you enter it on Command Prompt.) Usually on the screen shots I was using as a reference it was a successful operation. However, whenever I try to enter it on my command prompt, I get this message: "The boot configuration data store could not be opened." "Access is denied". I even tried to isolate on what DEP should leave as an exception, but it tells me that "this program needs to run with DEP enabled, you cannot turn off DEP for this program." Can anyone help me with this issue? I REALLY want to play Thief: Deadly Shadows, but this Data Execution Prevention crap is really frustrating. Thanks!
     
    thewhiteronin, Jul 29, 2011
    #1
    1. Advertisements

  2. thewhiteronin

    thewhiteronin

    Joined:
    Jul 29, 2011
    Messages:
    2
    Likes Received:
    0
    Nevermind, I solved the problem to my own question. All you need to do to disable the DEP via command console (for it to actually work), is to disable UAC FIRST. I hope this helps anyone who had the same problem as me. To disable UAC, go to Start --> Settings --> Control Panel --> User Accounts --> Click 'Turn User Account Control on or Off'.
     
    thewhiteronin, Jul 29, 2011
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.