Digital Microscope

Discussion in 'Audio & Video' started by 4cats, Nov 3, 2012.

  1. 4cats

    4cats

    Joined:
    Nov 3, 2012
    Messages:
    1
    Likes Received:
    0
    Have Windows Vista Home Premium fully updated. Trying to use a Celestron Digital Microscope which plugs into the USB port. I followed installation directions, the microscope was recognized instantly, and the software installed without problem. When I try to use it though, the software displays a message: "connecting to digital microscope" and then nothing ever happens. The software does know when the microscope is plugged in and when it isn't. The lights on the microscope light up but no picture is ever displayed. Have tried uninstalling, reinstalling from disc and from manufacturer's website - same thing. Have verified that I have the most current driver. Company shipped me another one but the same thing happens. Have tried two different versions of webcam software - ManyCam recognizes it but says that "the device is already in use with another application" even though I don't have anything else running. Have looked through various parts of the Vista Control Panel (device manager, application associations) and nothing seems to fit with this. Anyone have any suggestions? Thanks very much.
     
    4cats, Nov 3, 2012
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.