DHCP Client/Diagnostics Policy Service not running

Discussion in 'General Technical' started by boweasel, Sep 12, 2011.

  1. boweasel

    boweasel

    Joined:
    May 12, 2011
    Messages:
    12
    Likes Received:
    0
    Running 32 bit Vista Home Basic SP1.

    Cannot get online. When I hover the mouse over the network icon in the notification area, it reads, "Connection status unknown. The dependency service or group failed to start" When I try to diagnose the problem, I can't because the Diagnostics Policy Service is not running. When I try to Start the service, access is denied. Same scenario for the service DHCP Client.

    Meanwhile, I keep getting warnings that my firewall is not enabled. When I try to enable it, I get a message that the Security Center can't turn it on.

    I ran a full Malwarebytes scan and it found nothing wrong. I did a system restore to several days before the problem, but even though the restore completed successfully, it didn't change my (non)results.

    The Network and Sharing Center does not display the familiar PC monitor icon with a line to the Network and another line going from the Network to the Internet. Instead it just has the word Unknown with the caption the depencency or groiup failed to start

    I am at a loss.
     
    boweasel, Sep 12, 2011
    #1
    1. Advertisements

  2. boweasel

    boweasel

    Joined:
    May 12, 2011
    Messages:
    12
    Likes Received:
    0
    Two little commands, run as an administrator

    net localgroup administrators localservice /add
    net localgroup administrators networkservice /add


    I'd say 'thanks' but my heart wouldn't be in it.
     
    boweasel, Sep 16, 2011
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.