DEP - Data Execution Prevention

Discussion in 'General Technical' started by bEarishpArrot, Jun 22, 2007.

  1. bEarishpArrot

    bEarishpArrot

    Joined:
    Jun 22, 2007
    Messages:
    5
    Likes Received:
    0
    OK, so I installed a bunch of new vista updates, and was on my way to enjoying a little more of vista... or so I thought. I click on Firefox (sorry IE, can't stand you), which was working fine before. DEP then decides that I can't run Firefox, and shuts it down. Being an idiot, i used the command prompt and disabled DEP using the bcdedit commands. Now I can't run AIM either, DEP shuts it down. I can't restart DEP, even using 'bcdedit.exe /set {current} nx AlwaysOn', after I restart my computer I can't adjust the options for it, even though it keeps shutting my programs down. I have no idea what is going on. Please Help! THX
     
    bEarishpArrot, Jun 22, 2007
    #1
    1. Advertisements

  2. bEarishpArrot

    Jason

    Joined:
    Sep 26, 2005
    Messages:
    2,081
    Likes Received:
    0
    Location:
    Chicago,IL
    Thats odd that DEP would stop that many Apps, something must be messed up on your install. Also how are you launching Firefox? You may indeed have a virus, which is attached to firefox and is calling a .exe when you are launching it. Which is why DEP is killing the entire process. Try navigating to the firefox root folder and running it from there.

    You tried:

    bcdedit.exe /set {current} nx AlwaysOff

    Keeping your command prompt open, run your setup or other process being stopped by DEP. Then, to turn it back on again, do the same and run the following:

    bcdedit.exe /set {current} nx AlwaysOn
     
    Jason, Jun 22, 2007
    #2
    1. Advertisements

  3. bEarishpArrot

    bEarishpArrot

    Joined:
    Jun 22, 2007
    Messages:
    5
    Likes Received:
    0
    OK, I have a fresh install of Firefox now. I opened up cmd and turned off DEP, and left the cmd window open. When I ran Firefox, the same thing happened... "Firefox has stopped working"... "DEP has closed Firefox". I don't even have options now for DEP, even when I enable it and restart my system.
     
    bEarishpArrot, Jun 22, 2007
    #3
  4. bEarishpArrot

    spartacus1875

    Joined:
    Feb 12, 2007
    Messages:
    17
    Likes Received:
    0
    when running the applications that you want to run ie firefox, right click on it and select 'run as administrator'. this should stop DEP from closing the applications. this is rather annoying to have to do but should stop DEP from closing your programs
     
    spartacus1875, Jun 25, 2007
    #4
  5. bEarishpArrot

    dperry029

    Joined:
    Jul 1, 2007
    Messages:
    1
    Likes Received:
    0
    Run this:

    bcdedit.exe /set {current} nx OptIn



    This is the default setting. Just reboot after this and Firefox will run with no problem. This sets DEP to be used on Windows programs and services only, which excludes Firefox. You could also set it to OptOut instead of OptIn and then could exclude Firefox. This would enable DEP on all programs except the programs you tell it not to (ie. Firefox). The OptOut is the most secure, but also needs the most configuration.



    Daniel Perry
     
    dperry029, Jul 1, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.