D-Link Internet Adapter

Discussion in 'Drivers' started by Sir Bob, Jun 11, 2006.

  1. Sir Bob

    Sir Bob

    Joined:
    Jun 9, 2006
    Messages:
    7
    Likes Received:
    0
    This is my connection to the internet. I have a driver, but when I installed it, it got an error and my internet didnt work. Is there a Vista Driver for a D-Link Wireless G USB Adapter (DWL-G122).



    Thank you,



    Graham
     
    Sir Bob, Jun 11, 2006
    #1
    1. Advertisements

  2. Sir Bob

    Sir Bob

    Joined:
    Jun 9, 2006
    Messages:
    7
    Likes Received:
    0
    This is the errors I get when I log on:



    AirGCFG.exe - Entry Point Error

    "The procedure entry point apsSearchInterface could not be located in the dynamic link library wlanapi.dll"



    WZCSLDR2.exe - Entry Point Error

    "The procedure entry point apsGetReady could not be located in the dynamic link library wlanapi.dll"
     
    Sir Bob, Jun 11, 2006
    #2
    1. Advertisements

  3. Sir Bob

    Jason

    Joined:
    Sep 26, 2005
    Messages:
    2,081
    Likes Received:
    1
    Location:
    Chicago,IL
    Jason, Jun 11, 2006
    #3
  4. Sir Bob

    Sir Bob

    Joined:
    Jun 9, 2006
    Messages:
    7
    Likes Received:
    0
    I did both of those things, but when I try to let windows find one, it finds it, and then says there is a missing file, which is impossible, because I downloaded and tried about 4 times
     
    Sir Bob, Jun 11, 2006
    #4
  5. Sir Bob

    Sir Bob

    Joined:
    Jun 9, 2006
    Messages:
    7
    Likes Received:
    0
    I figured it out. My computer wouldnt accept the driver because It didnt have a signed certificate. I just had to F8 at the OS choices and say "Boot and disable Certificate verification" or somthing along those lines.
     
    Sir Bob, Jun 12, 2006
    #5
  6. Sir Bob

    Wagner Bertolini Junior

    Joined:
    Sep 20, 2006
    Messages:
    1
    Likes Received:
    0
    Did you solve the problem?

    I have already installed the new Vista Release Candidate 1 (RC1), and i have the same problem, i wanna know what driver do you use to solve the problem?

    You just install the drive and then boot with this option?

    a have already used this option, with the last driver from d-link, and it doesn´t work.

    Can you send me the driver that you have used?

    mail: [email protected]

    Thanks a lot
     
    Wagner Bertolini Junior, Sep 20, 2006
    #6
  7. Sir Bob

    T3h Bo55

    Joined:
    Oct 21, 2006
    Messages:
    1
    Likes Received:
    0
    T3h Bo55, Oct 21, 2006
    #7
  8. Sir Bob

    vidalsh

    Joined:
    Dec 6, 2006
    Messages:
    1
    Likes Received:
    0
    This is the errors I get when I log on:



    AirGCFG.exe - Entry Point Error

    "The procedure entry point apsSearchInterface could not be located in the dynamic link library wlanapi.dll"



    WZCSLDR2.exe - Entry Point Error

    "The procedure entry point apsGetReady could not be located in the dynamic link library wlanapi.dll"



    I have the same error...



    is there anyway to solve this?
     
    vidalsh, Dec 6, 2006
    #8
  9. Sir Bob

    ouija

    Joined:
    Jan 2, 2007
    Messages:
    6
    Likes Received:
    0
    I have the same probelm - Tried disabling the driver signature using F8, still not working. Has anyone managed to find a vista-compatible driver for the d-link DWL-G122? and if so, where can I find it? Let me know :)
     
    ouija, Jan 2, 2007
    #9
  10. Sir Bob

    ouija

    Joined:
    Jan 2, 2007
    Messages:
    6
    Likes Received:
    0
    I also have a D-Link DWL-122 (the "b" version) as well as the DWL-G122 (the "g" version), so if there are any compatible drivers for either of these under vista, please *please* let me know ;)
     
    ouija, Jan 2, 2007
    #10
  11. Sir Bob

    ouija

    Joined:
    Jan 2, 2007
    Messages:
    6
    Likes Received:
    0
    I FOUND A DRIVER THAT ACTUALLY WORKS WITH VISTA & WIN x64!

    And now that I got your attention, allow me to share this wonderful driver:

    http://www.megaupload.com/?d=SPDKFP56(mirror 1)

    http://www.sharebigfile.com/file/50182/G122-x64-Driver.zip.html(mirror 2)

    I have also uploaded this to driverguide.com in hopes that I will aid others in thier search for a vista compatible driver.

    The only thing that *might* cause issues is by installing this driver <U>without</U> disabling `driver certificates` using the F8 boot menu.

    Otherwise, Enjoy :)
     
    ouija, Jan 2, 2007
    #11
  12. Sir Bob

    Jez75

    Joined:
    Jan 13, 2007
    Messages:
    1
    Likes Received:
    0
    Ok ok, I've had the same issues as you guys, hence being on this forum. It appears the Dlink software doesn't link Vista, at least not yet. However the driver works fine. Try uninstalling the Dlink software, reboot and hit F8 and disable the forced signed driver option and once you're in, just expand the driver files that come with the Dlink software and manually install the driver through device manager and point to the driver files. This may prompt you that the driver is not signed by MS blah blah.. just over ride this and install it. Reboot and this should work fine. You should not longer get those errors at startup as the Dlink software is no longer installed. You don't need that crummy Dlink Wlan monitoring software anyway. Worked sweet for me :) Good luck!
     
    Jez75, Jan 13, 2007
    #12
  13. Sir Bob

    wplantz

    Joined:
    Feb 1, 2007
    Messages:
    4
    Likes Received:
    0
    Thanks Jez for the help...worked flawlessly!!:D ...If only now I could get my AVG error msg gone and make my AIM 5.5 w/DeadAIM to work properly :p
     
    wplantz, Feb 1, 2007
    #13
  14. Sir Bob

    peter111961

    Joined:
    Feb 10, 2007
    Messages:
    2
    Likes Received:
    0
    thanks vista newbie got mine to work a treat to just a note for the not so technical like myself as i fell foul of this in that i could not find the drivers and when i would uninstall dlink software it also unistalls the drivers as the drivers are not seperate on my disc i was unable to install just the drivers i eventually traced them to c:/programfiles/dlink/airplusg/drivers and copied the driver file to my documents hope this helps
     
    peter111961, Feb 10, 2007
    #14
  15. Sir Bob

    PhysEd

    Joined:
    Feb 27, 2007
    Messages:
    1
    Likes Received:
    0
    I had the same issue as SirBob, with the sameerror messages etc... But my wireless still connects once I have 'OK'd the error messages.

    The drivers I used were these:

    ftp://ftp.dlink.co.uk/wireless/dwl-g122_rev_Bx/dwl-g122_revBxCx_drv_v3.00.zip

    They are listed on the UK DLink site as below, so are XP drivers - but still seem to work with Vista Ultimate.

    <TABLE cellSpacing=0 cellPadding=0 width=460 border=0><TBODY><TR><TD style="BORDER-RIGHT: #f5ea81 1px solid; PADDING-RIGHT: 5px; BORDER-TOP: #f5ea81 1px solid; PADDING-LEFT: 5px; PADDING-BOTTOM: 5px; PADDING-TOP: 5px" align=middle width=50>3.00 </TD><TD style="BORDER-RIGHT: #f5ea81 1px solid; PADDING-RIGHT: 5px; BORDER-TOP: #f5ea81 1px solid; PADDING-LEFT: 5px; PADDING-BOTTOM: 5px; PADDING-TOP: 5px" align=left width=270>Drivers/Utility for Win98SE/ME/2000/XP (rev B1/C1) </TD><TD style="BORDER-RIGHT: #f5ea81 1px solid; PADDING-RIGHT: 0px; BORDER-TOP: #f5ea81 1px solid; PADDING-LEFT: 5px; PADDING-BOTTOM: 5px; PADDING-TOP: 5px" align=middle width=70>03-01-2006 </TD></TR></TBODY></TABLE>

    http://www.dlink.co.uk/

    This was my last resort after trying out numerous(5?)other DLink driver suggestions as well as the Vista BETA DLink drivers on the US DLink site (which didn't work, but then I am in the UK, so not surprising I guess ;))

    Good luck with these. If you are in the UK and have the Rev B USB DWL-G122, give them a go!
     
    PhysEd, Feb 27, 2007
    #15
  16. Sir Bob

    DwecUSER

    Joined:
    Feb 27, 2007
    Messages:
    1
    Likes Received:
    0
    The solution posted by Jez75 worked great for me, but I also have a problem where if I do not unplug my wireless adapter from the back of my computer before shutdown, it will restart instead of shutting down. I could really use some help on this. Thanks
     
    DwecUSER, Feb 27, 2007
    #16
  17. Sir Bob

    Turoq

    Joined:
    Apr 5, 2007
    Messages:
    1
    Likes Received:
    0
    To get rid of the error messages, which appear to be related to the tray icon, you can remove the following registry entries in folder:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    Entries:

    ANIWZCS2Service - REG_SZ - C:\Program Files\ANI\ANIWZCS2 Service\WZCSLDR2.exe

    and

    D-Link Air USB Utility - REG_SZ - C:\Program Files\D-Link\Air USB Utility\AirCfg.exe

    On my machine, theerror messages are gone, but the network connection is fine. My device is an oldDWL 122 Revision A using the latest XP-Drivers from the d-link website.

    Success,

    Tobias
     
    Turoq, Apr 5, 2007
    #17
  18. Sir Bob

    jbrubach

    Joined:
    May 10, 2007
    Messages:
    1
    Likes Received:
    0
    I run 4 computers on a D-Link Di 624 wireless router and have been using a D-Link WUA 2340 usb wireless adapter. The old mainboard cacked so installed the WUA 2340 on a new Compaq/Hp with Vista. Lo &amp; behold, the adapter installed apparently using the Vista software and the D-Link installation CD. It worked for several weeks, good solid connection, but got error messages with D-Link web pages every time I booted. Uninstalled the Driver using the system/control panel/other devices/network controller/uninstall. This deleted the adapter from device manager, however I now cannot reinstall the WUA 2340 adapter. Vista finds the "new Hardware" but cannot find the D-Link software on the D-Link CD. So I copied the drivers on the Cd and pasted them to the Compaq C drive, but still get the error message thatWindows cannot find the drivers. D-Link support staff advised that the are working on drivers for the WUA 2340 and suggested that I instead use a DWLG122 or wait for the new Driver. There are Vista drivers on their website, but I take it that these do not easily work!!. The WUA runs at 108 mps, while the 122 runs at 54mps. Sounds like similar problems described in this Topic. Anyone with an answer? I wonder if the Vista driver for the DWL G122 would work as it can bedownloaded from the D-Link site?
     
    jbrubach, May 11, 2007
    #18
  19. Sir Bob

    Walker

    Joined:
    Mar 19, 2007
    Messages:
    225
    Likes Received:
    0
    Got DWL-G510 on DLink Vista drivers. Works like a charm.....
     
    Walker, May 21, 2007
    #19
  20. Sir Bob

    Petetheman

    Joined:
    May 22, 2007
    Messages:
    1
    Likes Received:
    0
    Petetheman, May 22, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.