Connection to Internet lost after sleep

Discussion in 'Networking & Internet' started by jez_miles, Feb 26, 2007.

  1. jez_miles

    jez_miles

    Joined:
    Feb 26, 2007
    Messages:
    1
    Likes Received:
    0
    Hi

    I recently upgraded to Vista Business. I have my broadband connection hard wired into my desktop and a laptop connected wirelessly.

    I generally have my system set to go into sleep mode after an hour. The problem I am having is that when I bring the computer out of sleep mode the internet connection is lost.

    In network settings it says I am connected to my network but not the internet. I have to do one of 2 things, either renew the IP address or re-boot.

    This is such a frustrating issue and I never had this problem in the past. I have set the network adapter so the computer can't shut it down.

    I know one option is to not let the computer go into sleep mode but am wondering if there is another solution.

    Any advice appreciated

    Jez
     
    jez_miles, Feb 26, 2007
    #1
    1. Advertisements

  2. jez_miles

    Antrax

    Joined:
    Feb 13, 2007
    Messages:
    156
    Likes Received:
    0
    Have you also set the network adapter not to turn off in the bios? may not apply to you as the option may not be there though.
     
    Antrax, Feb 27, 2007
    #2
    1. Advertisements

  3. jez_miles

    DarthTedious

    Joined:
    Feb 28, 2007
    Messages:
    1
    Likes Received:
    0
    I have the exact same problem, except I get it on startup as well as after waking from sleep mode. I have to "repair" the connection and select the "automatically get new settings for network device" option from the repair menu to fix it after every startup. (Vista Home Premium on a Sony Vaio laptop)
     
    DarthTedious, Feb 28, 2007
    #3
  4. jez_miles

    Brian.Jackson

    Joined:
    Mar 19, 2007
    Messages:
    15
    Likes Received:
    0
    Location:
    VT, USA
    Hey guys,

    Vista has some new power management features that do the same thing you are describing. Try the following method:

    Right-Click your desktop ====> Select Properties ====> Click Screen Saver ====> At the bottom of the window will be a link Change Power Settings (Click it).

    Click on Change Plan Settings under your selected power scheme. ====> Click Advanced Power Settings and select your Wireless or Wired adapter and in the Power Saving Mode will be a drop down menu. Select Maximum Performance and click apply.

    Now your adapter will not go to sleep with the computer to conserve power.

    Brian
    Geeksquad COA
     
    Brian.Jackson, Mar 19, 2007
    #4
  5. jez_miles

    JayRock

    Joined:
    Mar 25, 2007
    Messages:
    3
    Likes Received:
    0
    For all of you I would recommend to check with Windows Update for a newer driver for your network card. Also check for BIOS updates from your motherboard manufacturer.
     
    JayRock, Mar 25, 2007
    #5
  6. jez_miles

    dinoman22

    Joined:
    Mar 28, 2007
    Messages:
    1
    Likes Received:
    0
    Driver updates from the manufacture DO HELP!!!



    So far my thoughts on Vista is a work in progress.

    Idk if M$ was rushed or what but Vista has flaws,

    I bought a Gateway Laptop for my girl, Wireless and everything worked fine...

    Then a day or so later i get a call from her while at work.."laptop isn't working online"

    I spent about an hour straight tweaking , going through the setup. My laptop was xp and ran flawlessly. I coulndt figure out why, i tried the IPV6 diabaling and using just ipv4, no luck, disable renable, power cycling modem and wireless router, dnsflush, ipconfig renews, and discos,

    I started to get a pissed...:angry:

    THE LAPTOP was new, 3 days old, and most problems associated with Vista searches showed the R2 beta vesion not home premium.



    I had remembered i put it to sleep mode , the night before...

    And then i stared to narrow my search on google

    I decided to check the manufactures site, i was relectant because it seemed like this could never be the issue.

    NO setting i adjusted in Vista worked.

    I had to Download the new drivers From GATEWAY and hope for the best....My wireless device says Realtek....AND i had the options or Broadcom or Intel.... I the chose INTEL drivr 185MBS LARGE file huh? YEP could be confusing for noobs and the ignorant.



    Long story Short ...DRIVER UPDATE WORKED!!! :w00t:

    and sure as shit the wireless fired up....

    ALL because of SLEEP MODE!!!



    Sorta of glad to have the laptop running vista not because of the gui, or anything positive it offers. But i wll make my job easier at an unamed ISP, when i have to troubleshoot

    POS stuff like this....:w00t:
     
    dinoman22, Mar 28, 2007
    #6
  7. jez_miles

    simoncu

    Joined:
    Mar 29, 2007
    Messages:
    1
    Likes Received:
    0
    Hi, I have the exact same problem. Vista Business on HP DC7600 with Broadcom NetXtreme gigabit net card.

    After sleep or inactivity. I have lost my net connection. Driver is updated, changed the power settings of the card, nada. I have the red cross either on both links (my computer - network - internet) or only on the link to internet.

    I have to repair the connection to be able to connect again. This pisses me off.



    Another problem I ran into, on a brand new toshiba, the wireless card could see the signal, but was unable to connect (repairing, trying to identify, I tried everything I could, - nothing. Impossible. And I know what I'm doing, I'm the main guy of the helpdesk of the IT center in our University.

    Any idea on how to disable all this stuff ?



    Simon
     
    simoncu, Mar 29, 2007
    #7
  8. jez_miles

    Tom Tucker

    Joined:
    Apr 1, 2007
    Messages:
    3
    Likes Received:
    0
    You can also set the adapter to not allow the computer to turn it off to save power. You do this by going into the network settings, right click your network connection (wired, wireless, etc...) then select properties. When the connection properties comes up click on the "configure" button next to the adapter then select the "power management" tab and turn off the "allow computer to turn off adapter to save power" option. Then you can still allow your PC to go to sleep but it won't turn off your adapter, the best of both worlds. I'm going off memory here since I'm working off my MAC today, if I misstated the path let me know and I'll fire up the Vista box to check out the exact path.
     
    Tom Tucker, Apr 1, 2007
    #8
  9. jez_miles

    Sue Scotland

    Joined:
    Apr 4, 2007
    Messages:
    3
    Likes Received:
    0
    Hi Tom,

    Thanks for your help but unfortunately it didn't work on my PC. The path you said led me straight to the 'power management 'tab, 'allow computer to turn off'etc but the loss of my connection still occurs when sleep state is entered.

    My only successful way to prevent loss of the connection is to set the sleep state to 'never'. Not really the ideal solution.

    I have spoken to Acer who manufacture my system and they say (if you can believe them) that they are working on it.
     
    Sue Scotland, Apr 4, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.