CD/DVD Drive does not appear in Explorer

Discussion in 'Drivers' started by japinkham, Feb 5, 2007.

  1. japinkham

    japinkham

    Joined:
    Feb 5, 2007
    Messages:
    1
    Likes Received:
    0
    HELP!!!!

    Since I loaded Vista Home Premium edition on Friday night, I have been having problems where it will not see my Sony CD/DVD drive. Everytime I reboot, I have to go into the device manager, scan for changes, and then it magically appears.

    Anybody have any idea why it is doing this. I have tried to updated the driver, but still same issue.

    Any assistance would be greatly appreciated!!!!
     
    japinkham, Feb 5, 2007
    #1
    1. Advertisements

  2. japinkham

    John Kincaid

    Joined:
    Feb 21, 2007
    Messages:
    3
    Likes Received:
    0
    Do you mean your DVD drive icon is not listed in "Computer" window?

    There is a possibility that you will have to update the dvd drive. However I can provide you a possibleresolution for this issue, please follow the steps correctly. You may need to delete the upper and lower filters of your system's registry.

    Here are the steps:

    Click the Windows Globe Logo and type under Start Search "Run"

    Select Run and Type in "regedit" without the quotes.
    Click on OK.

    Getting Started:
    - Click on Start.
    - Click on Run.
    - Type in "regedit" without the quotes.
    - Click on OK.
    NOTE: This will begin the Registry Editor that we utilize to perform this delicate procedure.

    Using the Registry Editor:
    - Click on the plus [+] sign to the left of "HKEY_LOCAL_MACHINE".
    - Continue clicking the plus [+] sign to the left of the following folders in this order:
    SYSTEM > CurrentControlSet > Control > Class

    NOTE: The next folder we are going to actually highlight instead of clicking on the plus. You will notice that these folders are not named, but instead contain a series of letters and numbers. The one we are looking for is called "{4D36E965-E325-11CE-BFC1-08002BE10318}". When you find it, single-click on the folder to highlight it and then proceed with the instructions below.

    Removing the Problem:
    - Look on right-hand side of the window for an icon called "Upperfilters" and/or "Lowerfilters".
    - Right-click on it and select "Delete" from the popup menu.
    - Repeat the same procedure until both "Upperfilters" and "Lowerfilters" have been removed.

    Saving Your Changes:
    - Exit any/all open programs.
    - Restart the computer for the changes to take effect.

    Once the computer has finished rebooting, your optical drives should be back under "Computer".

    :)
     
    John Kincaid, Feb 22, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.