Can't change User name in Connect dialog

Discussion in 'Security' started by Photonjunkie, Jan 23, 2011.

  1. Photonjunkie

    Photonjunkie

    Joined:
    Jan 23, 2011
    Messages:
    2
    Likes Received:
    0
    When I, as admin, attempt to access a password protected share on my NAS, the "User name:" field is grayed out in the connect-to dialog with "[computer name]\guest" already filled in. Since the share requires a specific user name, I'm unable to log-in even with the correct password.

    If I switch to the guest or another standard user account on the PC, the Connect to dialog's field will be blank and I can enter the correct user name and log-in to the share. I have no problem logging-in to this share from XP and Win7 boxes on the network.

    Other password protected shares on the same NAS are accessible from this box.

    How do I make the User name field editable in this dialog?

    The PC in question is running Vista (64 bit) with all current updates. The NAS is a Netgear ReadyNAS NV+.
     
    Photonjunkie, Jan 23, 2011
    #1
    1. Advertisements

  2. Photonjunkie

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Likes Received:
    2
    Location:
    Northern Virginia, USA
    Well, unless you intentionally unhid the "real" Administrator account, your not "admin"; instead, your a general class user with some elevated rights.

    Unlike with XP, Vista does not automatically make you a full Administrator when it sets up your account.

    So, you can go into the User Accounts in Control Panel, unhide the Administrator account -- and login under that.

    But, that may not fix the "NAS" problem -- and since that's third party stuff, have no idea how to fix it myself.
     
    WAW8, Jan 23, 2011
    #2
    1. Advertisements

  3. Photonjunkie

    Photonjunkie

    Joined:
    Jan 23, 2011
    Messages:
    2
    Likes Received:
    0
    Thanks for the suggestion. I have wondered where the real admin account was. And yes, if I log on as Administrator, the security dialog for the NAS share allows me to enter the correct user name. But I could also do that from the lowly Guest account and another standard user account. I'm still mystified why my superuser "Administrator" account doesn't have the option to change the login name for the share.
     
    Photonjunkie, Jan 24, 2011
    #3
  4. Photonjunkie

    okayo0

    Joined:
    Aug 27, 2011
    Messages:
    40
    Likes Received:
    0
    2 down vote accepted


    You need to use runas .. netonly when starting up SSMS to use Windows Authentication with different credentials (You might need to change the path to the executable depending upon what version you are on)

    runas /user:DOMAIN\USERNAME /netonly
    "C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Ssms.exe"

    NB: To future readers if you get a generic "invalid credentials" type message when trying this please read the comments trail
     
    okayo0, Nov 14, 2011
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.