Acer Aspire Laptop Synaptics Touchpad Issue

Discussion in 'Drivers' started by MossyRock, Apr 23, 2012.

  1. MossyRock


    Apr 23, 2012
    Likes Received:
    Mouse Click Issues

    Laptop is an Acer Aspire 4730z with Windows Vista Home Premium 32-bit, fully updated to current.

    I installed an update to Avast's engine, and after rebooting, when I got to the Windows logon screen, both the mouse buttons on both the built-in Synaptics touchpad and an external USB mouse will only select an item, but nothing else happens. In other words, if I click on a user account, it selects it but it doesn't allow me to enter a password. Likewise, if I click on the shutdown icon at the lower right of the screen, it just selects it but nothing else happens.

    But, I found that if I hit the tab key and then the enter key to select something on this screen, then the left mouse button starts working again on the touchpad and the USB mouse..

    When I get into windows, the left mouse button on both the built-in touchpad and the external mouse continue to work, but the right mouse button on the built-in touchpad doesn't work. However, the right mouse button on the USB mouse works.

    I have tried everything I can think of to resolve this:
    - uninstalled Avast (I'm now using MSE as the anti-virus on this machine)
    - uninstalled and re-installed the drivers for both mouse devices multiple times, using different versions (for the touchpad, one set of drivers from Acer, another set from Synaptics)
    - uninstalled the Synaptics device from device manager and let windows reinstall it upon reboot
    - updated the drivers within device manager (it didn't find any that were more current)
    - restored the system back to a system restore point before this started happening
    - dinked around with all the settings available for mouse
    - tried toggling FN+F7 (the Acer key to turn on/off the touchpad functions)
    - tried SAFE mode - same behavior
    - tried SAFE boot with nearly all services disabled

    I'm beginning to think this might not have anything to do with drivers since neither mouse device works correctly at the Windows login screen until I hit TAB and then ENTER. I think the internals of Vista may be hosed somewhere.

    Acer said that I should do a wipe and reset back to factory state. I'd sure like to avoid this.

    Any thoughts?

    Last edited: May 1, 2012
    MossyRock, Apr 23, 2012
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.