Windows Vista Forums


Reply
Thread Tools Display Modes

WIDCOMM Bluetooth Drivers

 
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 9
 
      16th September 2006, 02:05 AM
Hello,



I didn't see any posts here on Bluetooth so here is my problem/resolution...

I have a Zonet Bluetooth V 2.0dongle Supported with Broadcom WIDCOMM Drivers. My original install CD of course did not work with Vista.

I had it removed during my install of Vista RC1 and after getting up and running inserted it and Vista would recognize it as a USB Device but didn't have drivers for it.

When I would reboot my PC and load Vista it would lock up after the loading screen with the green bar... (XP still loaded fine)

There was even a time where if i inserted it while fulled booted in Vista it would lock my PC up solid and I would have to remove it and cold boot my PC.

To make a very, very long story short...after about 10 different versions of drivers,I finally found one that works...I don't remember where I found it but here is the filename...

Widcomm.32Bit.v5.0.1.2500.Incl.Lic.Patch.rar

I still have the file so if someone needs it send me an email or PM...

The site that I found it on also had the 64bit version...(don't have that one)

I also, after getting the drivers installed had problems with the license.dat file that WIDCOMM uses but that is what the patch is for I now have approx. 2,000,000 days left in my evaluation copy of this software.

This was very frustrating, and took a few nights/mornings to fix so if anyone else is having problems let me know and maybe I can help...

Good luck!!!
 
Reply With Quote
 
 
 
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 2
 
      20th September 2006, 08:31 AM
Hi I am looking for WIDCOMM driver for my Bluethooth device as the driver which came with the product doesn't work with Windows Vista RC1 eighter. Youmentioned you have the file. Could you be kind enough to shareit. My email is http://www.vistaforums.com/(E-Mail Removed). You might upload it to rapidshare and post the link. I as well as many other needed could download it from there.
 
Reply With Quote
 
 
 
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 1
 
      20th September 2006, 05:26 PM
Same problem here. I'd really appreciate your sending me the drivers to: (E-Mail Removed). Thanks.
 
Reply With Quote
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 1
 
      25th September 2006, 11:24 AM
Please would u email me the patch and driver to (E-Mail Removed)

thanks so much
 
Reply With Quote
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 1
 
      26th September 2006, 09:48 PM
Hello, please send me this software and drivers too. My email (E-Mail Removed)Thanks
 
Reply With Quote
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 9
 
      27th September 2006, 12:23 AM
Hello All,

As requested i finally got these drivers up on RapidShare...

The link is here...

i hope this works for everyone...no gurrentees tho...

Again this is only the 32bit version if you need the 64bit then please refferance the filename listed in my first post and "Google it" I had to dig for a while because it was on RapidShare as well and there isn't a direct link anywhere I just found it in another forum.



Good Luck!!!
 
Reply With Quote
 
Junior Member
Join Date: Sep 2006
Location:
Posts: 2
 
      1st October 2006, 08:44 AM
Thanks a lot:w00t:
 
Reply With Quote
 
Junior Member
Join Date: Oct 2006
Location:
Posts: 2
 
      2nd October 2006, 02:02 PM
could you sharedriver?
 
Reply With Quote
 
Junior Member
Join Date: Oct 2006
Location:
Posts: 2
 
      2nd October 2006, 02:02 PM
(E-Mail Removed)
 
Reply With Quote
 
Junior Member
Join Date: Oct 2006
Location:
Posts: 1
 
      14th October 2006, 05:57 AM
I finally have the Widcomm 5.0.1.2500 x64 fully functional on Vista RC1 AMD x64 with Logitech CSR Bluetooth Hub used by DiNovo and MX-900 set. Had to jump thru hoops to get it to work!!!



Here are some things I learned:



- start Vista RC1 via F8 key and selecting "Disabled Driver Signature Enforcement" option

- make sure u have a lhid2hci.exe tool

- run Widcomm setup as an admin

- do not have your dongle connected until after install restart

- after restart, run lhid2hci tool before using Widcomm

- when Widcomm installs double check that u have both the enumerator and wireless hub under "Bluetooth Devices" in your Device Manager

- if you only have the hub, it won't work

- if enumerator and hub are properly installed, Widcomm will also install a slew of other devices: Com ports, modems, HID drivers for kbd and mouse, icons, tools, etc. etc. etc.

- each Vista Boot or wake-up requires lhid2hci.exe tool to run. So I added the tool to the start-up to take care of boots. On wake-ups, I run it manually via desktop shortcut. It would make sense to just add it to Sched Tasks and conditional on power events



Personal Note: my own install had to be done by hand since I messed up my oem.inf files. If u get into the same situation after trial and error attempts, use DPInst.exe tool to install btkrnl.inf (the enumerator) and btwusb.inf (the hub) etc. manually





Hope this will help someone and save lots of time and frustration!!!

JS
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to reset/clear Bluetooth drivers? airzoink General Technical 0 16th October 2007 02:29 AM


All times are GMT. The time now is 02:24 PM.
Vista Forums is an independent website and is not affiliated with Microsoft Corporation.