WIDCOMM Bluetooth Drivers

Discussion in 'Drivers' started by bg8ball2, Sep 16, 2006.

  1. bg8ball2

    bg8ball2

    Joined:
    Sep 15, 2006
    Messages:
    9
    Hello,



    I didn't see any posts here on Bluetooth so here is my problem/resolution...

    I have a Zonet Bluetooth V 2.0dongle Supported with Broadcom WIDCOMM Drivers. My original install CD of course did not work with Vista.

    I had it removed during my install of Vista RC1 and after getting up and running inserted it and Vista would recognize it as a USB Device but didn't have drivers for it.

    When I would reboot my PC and load Vista it would lock up after the loading screen with the green bar... (XP still loaded fine)

    There was even a time where if i inserted it while fulled booted in Vista it would lock my PC up solid and I would have to remove it and cold boot my PC.

    To make a very, very long story short...after about 10 different versions of drivers,I finally found one that works...I don't remember where I found it but here is the filename...

    Widcomm.32Bit.v5.0.1.2500.Incl.Lic.Patch.rar

    I still have the file so if someone needs it send me an email or PM...

    The site that I found it on also had the 64bit version...(don't have that one)

    I also, after getting the drivers installed had problems with the license.dat file that WIDCOMM uses but that is what the patch is for ;) I now have approx. 2,000,000 days left in my evaluation copy of this software.

    This was very frustrating, and took a few nights/mornings to fix so if anyone else is having problems let me know and maybe I can help...

    Good luck!!!
     
    bg8ball2, Sep 16, 2006
    #1
    1. Advertisements

  2. bg8ball2

    siddharth_jayaraman

    Joined:
    Sep 20, 2006
    Messages:
    2
    Hi I am looking for WIDCOMM driver for my Bluethooth device as the driver which came with the product doesn't work with Windows Vista RC1 eighter. Youmentioned you have the file. Could you be kind enough to shareit. My email is siddharth_jayaraman@yahoo.com. You might upload it to rapidshare and post the link. I as well as many other needed could download it from there.
     
    siddharth_jayaraman, Sep 20, 2006
    #2
    1. Advertisements

  3. bg8ball2

    romerojc

    Joined:
    Sep 20, 2006
    Messages:
    1
    Same problem here. I'd really appreciate your sending me the drivers to: romero.jc@gmail.com. Thanks.
     
    romerojc, Sep 20, 2006
    #3
  4. bg8ball2

    h3l0

    Joined:
    Sep 25, 2006
    Messages:
    1
    h3l0, Sep 25, 2006
    #4
  5. bg8ball2

    Mychu

    Joined:
    Sep 26, 2006
    Messages:
    1
    Hello, please send me this software and drivers too. My email mychu@tlen.plThanks
     
    Mychu, Sep 26, 2006
    #5
  6. bg8ball2

    bg8ball2

    Joined:
    Sep 15, 2006
    Messages:
    9
    Hello All,

    As requested i finally got these drivers up on RapidShare...

    The link is here...

    i hope this works for everyone...no gurrentees tho...

    Again this is only the 32bit version if you need the 64bit then please refferance the filename listed in my first post and "Google it" I had to dig for a while because it was on RapidShare as well and there isn't a direct link anywhere I just found it in another forum.



    Good Luck!!!
     
    bg8ball2, Sep 27, 2006
    #6
  7. bg8ball2

    siddharth_jayaraman

    Joined:
    Sep 20, 2006
    Messages:
    2
    Thanks a lot:w00t:
     
    siddharth_jayaraman, Oct 1, 2006
    #7
  8. bg8ball2

    jdcollns

    Joined:
    Oct 2, 2006
    Messages:
    2
    could you sharedriver?
     
    jdcollns, Oct 2, 2006
    #8
  9. bg8ball2

    jdcollns

    Joined:
    Oct 2, 2006
    Messages:
    2
    jdcollns, Oct 2, 2006
    #9
  10. bg8ball2

    jstoman

    Joined:
    Oct 14, 2006
    Messages:
    1
    I finally have the Widcomm 5.0.1.2500 x64 fully functional on Vista RC1 AMD x64 with Logitech CSR Bluetooth Hub used by DiNovo and MX-900 set. Had to jump thru hoops to get it to work!!!



    Here are some things I learned:



    - start Vista RC1 via F8 key and selecting "Disabled Driver Signature Enforcement" option

    - make sure u have a lhid2hci.exe tool

    - run Widcomm setup as an admin

    - do not have your dongle connected until after install restart

    - after restart, run lhid2hci tool before using Widcomm

    - when Widcomm installs double check that u have both the enumerator and wireless hub under "Bluetooth Devices" in your Device Manager

    - if you only have the hub, it won't work

    - if enumerator and hub are properly installed, Widcomm will also install a slew of other devices: Com ports, modems, HID drivers for kbd and mouse, icons, tools, etc. etc. etc.

    - each Vista Boot or wake-up requires lhid2hci.exe tool to run. So I added the tool to the start-up to take care of boots. On wake-ups, I run it manually via desktop shortcut. It would make sense to just add it to Sched Tasks and conditional on power events



    Personal Note: my own install had to be done by hand since I messed up my oem.inf files. If u get into the same situation after trial and error attempts, use DPInst.exe tool to install btkrnl.inf (the enumerator) and btwusb.inf (the hub) etc. manually





    Hope this will help someone and save lots of time and frustration!!!

    JS
     
    jstoman, Oct 14, 2006
    #10
  11. bg8ball2

    jaiminrajani

    Joined:
    Mar 30, 2007
    Messages:
    1
    jaiminrajani, Mar 30, 2007
    #11
  12. bg8ball2

    earthmarble

    Joined:
    Apr 26, 2007
    Messages:
    2
    I'm right where you were. I installed the widcomm drivers and if I boot with the USB device inserted, the system hangs hard. If I insert the device after booting, the system hangs hard.



    The widcomm drivers and software do not have an uninstall and do not allow a roll-back. How do I remove them? Do a checkpoint restore?
     
    earthmarble, Apr 26, 2007
    #12
  13. bg8ball2

    earthmarble

    Joined:
    Apr 26, 2007
    Messages:
    2
    OK...I tried restoring from 5 checkpoints prior to the install of the WIDCOMM bluetooth drivers and they all failed due to an "unspecified error"....and left me where I started.



    I may have to go back to the DVD I made when I bought the laptop to get these drivers off cleanly...and I'd really like to not have to do that.



    Off to Google to find out if they can be removed manually......because until they have been removed, I can't insert the bluetooth dongle without locking the system hard instantly.
     
    earthmarble, Apr 26, 2007
    #13
  14. bg8ball2

    dfryfy

    Joined:
    Jul 9, 2007
    Messages:
    1
    hello there.

    i read your posting and i face the same problem too.

    can u pls email me the patch to my email,

    dfryfy@gmail.com

    thank you very much.
     
    dfryfy, Jul 9, 2007
    #14
  15. bg8ball2

    nufcbabe

    Joined:
    Sep 16, 2007
    Messages:
    1
    Hi :)

    i was wondering if any1 can help me, ive got a mikomi v2 bluetooth adapter. i installed the drivers but its crashed the system and kept restarting the laptop. cos its not compatable wiv vista, does any1 kno how i can get around this or find a driver thts compatable wiv vista 4 the device.
     
    nufcbabe, Sep 16, 2007
    #15
  16. bg8ball2

    sudharsan

    Joined:
    Mar 2, 2008
    Messages:
    1
    hiii i'm looking for driver for my trust bluetooth usb dongle.

    can u help me.

    thanks
     
    sudharsan, Mar 2, 2008
    #16
  17. bg8ball2

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Location:
    Northern Virginia, USA
    WAW8, Mar 7, 2008
    #17
  18. bg8ball2

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Location:
    Northern Virginia, USA
    nufcbabe:



    Did you keep the packaging? The drivers are on a small disk -- hard to find, but they're in there.



    I read that it uses Bluesoleil Software. Google on that and see what you can find.
     
    WAW8, Mar 7, 2008
    #18
  19. bg8ball2

    Sez

    Joined:
    Apr 1, 2008
    Messages:
    1
    I downloaded all the drivers and doesnt work for me still. My problem is that the Windows Defender blocks it in the middle of the instalation. Any help will be appreciated. Mine is a WIDCOMM Bluetooth too and I have Windows Vista with SP1.
     
    Sez, Apr 2, 2008
    #19
  20. bg8ball2

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Location:
    Northern Virginia, USA
    OK, so turn off or disable Windows Defender!
     
    WAW8, Apr 2, 2008
    #20
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ulyanov77

    Bluetooth Folder

    ulyanov77, Mar 6, 2007, in forum: General Technical
    Replies:
    1
    Views:
    716
    ulyanov77
    Mar 8, 2007
  2. airzoink

    How to reset/clear Bluetooth drivers?

    airzoink, Oct 16, 2007, in forum: General Technical
    Replies:
    0
    Views:
    2,806
    airzoink
    Oct 16, 2007
  3. kustomizedstang
    Replies:
    8
    Views:
    9,176
  4. kustomizedstang
    Replies:
    1
    Views:
    3,414
  5. TAZORAC
    Replies:
    6
    Views:
    936
Loading...