Digital Still Camera

Discussion in 'Drivers' started by tatankha, Mar 22, 2012.

  1. tatankha

    tatankha

    Joined:
    Mar 18, 2012
    Messages:
    7
    Hello
    My computer doesn't recognize my Nikon D7000 anymore when plugged in. The device manager shows error sign along with the Digital Still Camera logo under Portable Devices . As a consequence Windows try to install a driver for my DSLR every time I plug it but with no success
    Is there a way to reinstall the Digital Still Camera driver or the Portable Device driver or service?. Uninstalling it from the device manager doesn't work. Microsoft website indicate that instead of Windows Protocol Devices the camera should use the Picture Transfer Protocol to solve the problem and the camera should be configure to use PTP!! I don't see how I can do that.
    When I try to connect a multi card reader with one of my 16GB SD memory card from my DSLR I get the same error signs under Portable Devices for each card reader slot (ie G, H, I, K). The multicard reader slots are visible under device and removable storage but all empty!

    By the way the camera worked fine with my computer 2 weeks ago.....
    My computer was recently repaired with Trinity rescue kit to regain administrator control...

    Update: I restored registries from before the Trinity rescue kit episode but it did not help

    Thanks a lot for your help
     
    Last edited: Mar 22, 2012
    tatankha, Mar 22, 2012
    #1
    1. Advertisements

  2. tatankha

    WAW8

    Joined:
    Jan 27, 2007
    Messages:
    3,541
    Location:
    Northern Virginia, USA
    First place you should check is the Nikon website to see what drivers and firmware they have posted for your camera that will work with Vista.

    I have an old Sony Handycam Video camera and I had to download a driver update for Win7 when I upgraded to that.
     
    WAW8, Mar 23, 2012
    #2
    1. Advertisements

  3. tatankha

    tatankha

    Joined:
    Mar 18, 2012
    Messages:
    7
    Nikon answered me that they don't provide driver for the camera. It use the Windows or Mac drivers.
    The problem is the same with a different digital camera (Canon) I tried to plug in!

    Is there a way to know if under properties of " portable devices' in device manager, the drivers list available is the right one?

    My Nikon worked perfectly with my computer 2 weeks ago. I just upgraded the Nikon firmware 1 hour ago......the problem is still here. This is a Vista problem. How to reinstall those Portable device drivers!!!???

    A serious help would be appreciated!!! HELP!!!!
     
    Last edited: Mar 25, 2012
    tatankha, Mar 23, 2012
    #3
  4. tatankha

    tatankha

    Joined:
    Mar 18, 2012
    Messages:
    7
    Hello
    I still have this error with the Digital Still Camera (under portable devices) when I connect my Nikon DSLR D7000.

    I have the "setuppapi.dev" log of what happens when the camera is plugged in. Unfortunately this file is too big to attach (25KB!!?!?!) I spoted a "device has PnP problem" How to fix this if this is THE problem?
    Thank for your help!
    Sincerely
    RG
     
    tatankha, Mar 26, 2012
    #4
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bardley

    Sony DSC-S75 Digital Camera

    bardley, Sep 14, 2006, in forum: Drivers
    Replies:
    2
    Views:
    2,416
    pholvoet
    Jul 1, 2007
  2. Chris Mattison

    Digital Sound

    Chris Mattison, Feb 17, 2007, in forum: Audio & Video
    Replies:
    0
    Views:
    1,358
    Chris Mattison
    Feb 17, 2007
  3. yanni247

    Vista 64 and ALC850 Digital audio out

    yanni247, May 8, 2007, in forum: Installation & Compatibility
    Replies:
    1
    Views:
    790
  4. toroyo
    Replies:
    0
    Views:
    1,054
    toroyo
    Apr 9, 2010
  5. kerriannec31

    Upside down camera with no drivers

    kerriannec31, Oct 27, 2011, in forum: Drivers
    Replies:
    0
    Views:
    552
    kerriannec31
    Oct 27, 2011
Loading...