Windows Vista Forums


Reply
Thread Tools Display Modes

Digital Still Camera

 
 
Junior Member
Join Date: Mar 2012
Posts: 7
 
      22nd March 2012, 02:18 PM
Hello
My computer doesn't recognize my Nikon D7000 anymore when plugged in. The device manager shows error sign along with the Digital Still Camera logo under Portable Devices . As a consequence Windows try to install a driver for my DSLR every time I plug it but with no success
Is there a way to reinstall the Digital Still Camera driver or the Portable Device driver or service?. Uninstalling it from the device manager doesn't work. Microsoft website indicate that instead of Windows Protocol Devices the camera should use the Picture Transfer Protocol to solve the problem and the camera should be configure to use PTP!! I don't see how I can do that.
When I try to connect a multi card reader with one of my 16GB SD memory card from my DSLR I get the same error signs under Portable Devices for each card reader slot (ie G, H, I, K). The multicard reader slots are visible under device and removable storage but all empty!

By the way the camera worked fine with my computer 2 weeks ago.....
My computer was recently repaired with Trinity rescue kit to regain administrator control...

Update: I restored registries from before the Trinity rescue kit episode but it did not help

Thanks a lot for your help

Last edited by tatankha; 22nd March 2012 at 07:48 PM..
 
Reply With Quote
 
 
 
 
Super Moderator
Join Date: Jan 2007
Location: Northern Virginia, USA
Posts: 3,541
 
      23rd March 2012, 12:39 PM
First place you should check is the Nikon website to see what drivers and firmware they have posted for your camera that will work with Vista.

I have an old Sony Handycam Video camera and I had to download a driver update for Win7 when I upgraded to that.
 
Reply With Quote
 
 
 
 
Junior Member
Join Date: Mar 2012
Posts: 7
 
      23rd March 2012, 01:05 PM
Nikon answered me that they don't provide driver for the camera. It use the Windows or Mac drivers.
The problem is the same with a different digital camera (Canon) I tried to plug in!

Is there a way to know if under properties of " portable devices' in device manager, the drivers list available is the right one?

My Nikon worked perfectly with my computer 2 weeks ago. I just upgraded the Nikon firmware 1 hour ago......the problem is still here. This is a Vista problem. How to reinstall those Portable device drivers!!!???

A serious help would be appreciated!!! HELP!!!!

Last edited by tatankha; 25th March 2012 at 01:12 AM..
 
Reply With Quote
 
Junior Member
Join Date: Mar 2012
Posts: 7
 
      26th March 2012, 04:01 AM
Hello
I still have this error with the Digital Still Camera (under portable devices) when I connect my Nikon DSLR D7000.

I have the "setuppapi.dev" log of what happens when the camera is plugged in. Unfortunately this file is too big to attach (25KB!!?!?!) I spoted a "device has PnP problem" How to fix this if this is THE problem?
Thank for your help!
Sincerely
RG
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony DSC-S75 Digital Camera bardley Drivers 2 1st July 2007 02:41 PM


All times are GMT. The time now is 01:33 PM.
Vista Forums is an independent website and is not affiliated with Microsoft Corporation.